FTDI-chip reprogrammed?

Hi everyone

I'm afraid I accidentally reprogrammed the FTDI-chip (with the use of USBTransfer tool -> http://www.ftdichip.com/Projects/CodeExamples/CSharp/USBTransfer.zip -be carefull with it please-) and now is my Arduino board acting strange like:

  • TX and RX-led are on (and stay on) when plugging into USB
  • Arduino board is now recognized as a 'USB to Serial' device instead of 'FT232RL USB UART '

I do have the same problem on my other pc (where I didn't change anything to the software/Arduino environmen etc.). So it must be the board. I'm guessing it is the FTDI (I did a EE_READ and EE_WRITE :()

I hope someone or a board developer can help me out of this mess :'(, I'm missing my lovely board ;)

I tried the same and my board (with FT232BL) is still working. I see an option in USBTransfer that says EEWriteDef (set to default). I don't know if it works, but you can try. The Arduino board uses the FTDI chip with the default settings.

Hope this helps.

Hi nkcelectronics

Thanks for the info.

I did an EEWriteDEf, and also installed the newest drivers.

Now the Arduino is recognized as "USB Serial Converter" and "USB Serial Port (COM14)".

The TX and RX led on the board are now "off" when there is no data send or transmit. When I try to upload a sketch to the board, the TX led flickers one time (very short) en the Arduino IDE (0007 Alpha) is returning: "Programmer is not responding". Tried the 0009 Alpha also -> "avrdude: ser_open(): can't open device "COM14": Het systeem kan het opgegeven bestand niet vinden."

A few days before this problem, I was able to upload sketches...

I do hope someone can help me (and my Arduino board :))

Greetings and thanks in advance

Try changing the serial port to a number less than 9.

I removed all the Bluetooth ports…

Now Arduino is @ COM Port 6 (‘USB Serial Converter’ → USB HUB as well as ‘USB Serial Port (COM6)’) are visible in Control Panel > System > …

I reprogrammed the FTDI-chip with the default settings from the datasheet.

What still looks strange is when I press the ‘RESET’-button, the LED @13 don’t flash for a short time when the bootloader is loaded… (I also replaced the ATMEGA168 with a new one which came with a preprogrammed bootloader on it). The POWER led is indicating that the Arduino board is powered bij USB (of course ;))

Maybe can someone with the information above do some ‘in brain debugging’? :wink: lol

Feeeeeeeeew, I’m almoast out of options I’m afraid…

Thanks in advance for the help! :slight_smile:

Hmm, where'd you get the ATmega168 from? Do you know which bootloader it has on it? What happens when you try to upload a sketch?

Hmm, where’d you get the ATmega168 from?

Italy: PCB Europe (smartprojects [at] tiscali [dot] it)

Do you know which bootloader it has on it?

According to PCB Europe → ATMega168 16K microcontroller with pre-loaded Arduino bootloader

What happens when you try to upload a sketch?

Arduino-0007 Alpha → 1) TX-flashing once
2) Error message → “Programmer is not responding.”
Arduino-0009 Alpha → 1) TX-flashing several times, 1 second nothing, flashes once…
2) 5 seconds ‘nothing’
3) Error message → “avrdude: stk500_getsync(): not in sync: resp=0x00”
“avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51”

(Both “USB Serial Port(COMS6)” and “USB Serial Converter” are showing op when the Arduino board is connected)

Hmm, if you reset the board, does the LED on pin 13 flash once? If not, it sounds like you got a chip that doesn’t actually have the bootloader on it. If it does flash, it may be that the FTDI chip is still incorrectly configured.

Hmm, if you reset the board, does the LED on pin 13 flash once?

No -> I replaced the new ATMEGA168 with the old one -> LED on pin 13 flash once ;D

Then I reprogrammerd the default settings into the FTDI-chip...

And it is working!!! ;D ;D ;D

Thanks a lot mellis and the others :-)

I can play again with my Arduino ;D Wihaaaaa

I would like to post the default settings in MProg-format, is there somewhere space available at arduino.cc of the playground? If someone has the same problem(s) it could be handy :-)

Go ahead and post it on the playground. You should be able to upload files if you need to. Let me know if you have any problems.

With pleasure :wink: