FTDI Problem (or an Adam problem)

I'm a complete novice so bear with me here.. I have a mac running os 10.6.7 (Intel). I loaded the Arduino software but the driver won't show up. Under Tools/Serial Port/ all I get is four bluetooth addresses. I have deleted/ reinstalled/ rebooted countless times. I looked in the system profiler and nothing "FTDI looking" is is in the USB section or the Extensions section. I have looked on a few forums and tried to follow the directions from similar sounding problems but I think that they are too outdated. (or I am doing something wrong) The arduino I am using is a ATmega1280. When I plug it in the red "power" led lights up and another blinks (red). Is another extension conflicting with the FTDI extension? If so how do I determine which one? Or is this some kind of compatibility issue with FTDI and 10.6.7? I need some Arduino super geek voodo! Thanks, Adam

Have you installed the FTDI driver?


Or more specifically:



I'm using OS/X 10.6.7 and it all works pretty smoothly.

I downloaded 2.2.16 and installed. I can see a file called FTDIUSBSerialDriver.kext in my system extensions folder. The system profiler cant seem to see it nor can my Arduino application. (and I did restart after each attempt at installation) Are there other files that I should manually delete and then try and reinstall? Other threads mentioned deleting files in the cache and receipts files but that was for older os versions.

OK. Well it isn't the OS itself, as that is the one I use. How are you connecting? Via the USB interface (not an FTDI cable)?

Did you do what it said here?


It says the drivers come with the distribution, and also to run macosx_setup.command

It was the cable. facepalm

I was using the cable that came with the Arduino. I switched it with my printer usb cable and it worked. Thanks Nick.

Glad it worked. I was having trouble finding a - um how do I put this? - Mac that didn't have Arduino on it to see exactly what steps I took last time.

In general Arduino IDE works like a dream on the Mac.