FTDI USB serial converter not recognized

Hi all,

My PC won't always recognize my Diecimila -- say only about 1 of each 20 attempts. A "USB device not recognized" balloon pops up in the taskbar, and "Unknown device" appears in the USB Controllers branch inside Device Manager, instead of "USB Serial Converter". Whenever this happens FTDI's USBView says "DeviceFailedEnumeration" and all values are zeroes.

I've tried many things, including resetting the Arduino, changing the USB port, removing other USB devices, removing the AtMega, downloading a new driver from ftdichip.com, testing on another PC, powering the device via a 9 V battery, powering it via the 5V pin using an external 5 V power supply... but nothing guarantees sure-fire recognition.

Please note that the board seems to be working; it is successfully recognized now and then in both computers. When this happens I can program the Arduino normally.

My config is:

Tatuino (an Arduino Diecimila clone using an AtMega8 and FT232B) Arduino software version 0011 1st PC is eeePC model 701 2nd PC is an old Evo N400C Both running Windows XP Home Edition with all updates

Any help is appreciated. Thanks a lot!

Have you tried asking the makers of your board for help?

Hello,

Sounds like the Tatuino is the problem, and not any certain pc.

Two ideas:

  1. Mess with the ports on winxp as per this thread:http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1211945050

  2. Here's something I have not tried but might help you: The Ftdi site has a utility http://www.ftdichip.com/Resources/Utilities.htm that might help you.

I noticed that the microcontroller board you are using is practically unknown according to google, though the ftdi chip is everywhere. :) I can vouch for Modern Device's BBB under WinXp and this cable: http://www.ftdichip.com/Products/EvaluationKits/TTL-232R.htm

Good luck, and be sure to update your thread when you find a solution.

Steve.

Have you tried asking the makers of your board for help?

Yes, but they didn't answer me yet. I'll contact them again, let's see.

@optique: Thanks for the tips, I'll try those later and I'll let you know when I have something. Thanks!!!

Done! The vendor answered, and the solution was simply to solder pins 25 and 26 of the FT232R together. I did it and it seems the problem is gone!

I hope this helps other users as well.

Thanks again for the tips!

Uh-oh... Spoke too early. The PC recognizes the board, but now I can't program it anymore... I always get the following:

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: failed to write flash memory, rc=-4
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I'm still testing, but I think I'll have to return the board. Oh well...

The manufacturer replaced the board, and (at last) everything seems to be working fine now. Just one minor flaw now… the two 100 uF capacitors are missing. They must have serious problems in the QC department!