Funksteckdose ansteuern ohne Fernbedienung

volvodani: Deswegen 12V auf die Funke Empfänger dran und auslesen und dann kann man es am schnellsten umsetzten

Das ist das frustfreiheste Vorgehen. Zur Not findet sich die nötige Batterie oft in Autotürschlossfernbedienungen. Bei meinem letzten Kauf war sie bei Rossmann im stationären Handel am günstigsten. Vielleicht hat man auch in 1Euro Läden Glück. Ansonsten gibt es sie im Versandhandel ab 55Cent.

Und eine Rückmeldung mit einem Ergebnis wären auch sehr interessant.

Ich habe schon versucht das mit meinem Labornetzteil hin zu bekommen,
aber leider liefert das nicht die benötigten 23A.
Wenn ich da die 12 Volt drauf gebe, dann Leuchtet die Led die ganze Zeit
und mein Arduino gibt mir dann auch keine Frequenz aus.

Probiert habe ich das mit dem Code:

/*
  Simple example for receiving
  
  http://code.google.com/p/rc-switch/
*/

#include <RCSwitch.h>

RCSwitch mySwitch = RCSwitch();

void setup() {
  Serial.begin(9600);
  mySwitch.enableReceive(0);  // Receiver on inerrupt 0 => that is pin #2
}

void loop() {
  if (mySwitch.available()) {
    
    int value = mySwitch.getReceivedValue();
    
    if (value == 0) {
      Serial.print("Unknown encoding");
    } else {
      Serial.print("Received ");
      Serial.print( mySwitch.getReceivedValue() );
      Serial.print(" / ");
      Serial.print( mySwitch.getReceivedBitlength() );
      Serial.print("bit ");
      Serial.print("Protocol: ");
      Serial.println( mySwitch.getReceivedProtocol() );
    }

    mySwitch.resetAvailable();
  }
}

Habe auch den Seriellen Monitor angemacht, aber er hat mir damit nichts angezeigt.

Gibt es da noch ne andere Möglichkeit ohne mir jetzt noch ne Batterie zu kaufen???

MFG

Black Zero

blackzero23: Ich habe schon versucht das mit meinem Labornetzteil hin zu bekommen, aber leider liefert das nicht die benötigten 23A. Wenn ich da die 12 Volt drauf gebe, dann Leuchtet die Led die ganze Zeit und mein Arduino gibt mir dann auch keine Frequenz aus.

Die 23A sind die Bezeichnung des Formfaktor (28mmx10mm) und der Spannung. Diese Minibatterie wäre mit 23A auch heillos überfordert. Für 23A braucht man schon so was wie eine Autobatterie.

Welche Led leuchtet dauerhaft? Reagieren die Steckdosen?

Ich teste immer gerne den Empfänger mit dem Sketch Button. Ich schließe den Empfänger als Button an und beobachte das Blinken der Led auf Pin 13.

Ups... Da hast du etwas falsch verstanden. Die Bezeichnung "23A" ist keine Stromangabe, sondern eine TypenBezeichnung. Eine Batterie in der Größe liefert auch keine 23 A. Ein Strom von 50 mA sollte da völlig ausreichen. Wenn das nicht funktioniert, ist irgend was an der Fernbedienung defekt. Der Sketch ist sicher der Original Beispielsketch und sollte funktionieren.

Ok, dann bin ich da ja schon ein bischen schlauer.

Normalerweise leuchtet die LED der Fernbedienung immer kurz auf wenn ich eine Taste drücke.

Wenn ich die allerdings an das Netzteil anschließe und es auf 12 Volt stelle, dann leuchtet die LED dauerhaft.

Die Steckdose reagiert weder auf die Fernbedienung noch auf den Sender.

Bei der Fernbedienung bin ich mir nicht sicher wegen dem Netzteil, aber die Steckdosen funktionieren eigentlich einwandfrei.

Ich weiß nur leider nicht wo der Fehler liegt.

MFG

Black Zero

blackzero23: Normalerweise leuchtet die LED der Fernbedienung immer kurz auf wenn ich eine Taste drücke.

Wenn ich die allerdings an das Netzteil anschließe und es auf 12 Volt stelle, dann leuchtet die LED dauerhaft.

Die Steckdose reagiert weder auf die Fernbedienung noch auf den Sender.

Dann muss etwas an der FB faul sein. Mit 12 Volt soll die funktionieren.

was ist das für ein Netzteil ? Ist die Spannung stabil und sauber ?

Bei der Fernbedienung bin ich mir nicht sicher wegen dem Netzteil, aber die Steckdosen funktionieren eigentlich einwandfrei.

Woher willst du wissen, dass die Steckdosen funktionieren, wenn die FB und der Sender nicht funktionieren.

Es geht nicht um eine CR123 sondern um ein 23-Batterie. Das ist eine kleine 12V-Batterie, sehr gerne in kleinen 433-Mhz-Fernbedienungs-Sendern z.B. auch in Autoschlüsseln eingesetzt wird: http://www.pollin.de/shop/dt/MjI4OTI3OTk-/Stromversorgung/Batterien/Alkali_Batterien/Alkaline_Batterie_L1028.html

Ich hoffe mal, du hast die Fernbedienung nicht durch das Netzteil zerstört.

Theseus: Es geht nicht um eine CR123 sondern um ein 23-Batterie. Das ist eine kleine 12V-Batterie, sehr gerne in kleinen 433-Mhz-Fernbedienungs-Sendern z.B. auch in Autoschlüsseln eingesetzt wird:

Na ja, dann ziehe ich meinen vorangegangenen Beitrag zurück und lösche ihn mit "Remove".

BYE

Kannst du denn den Funkcode, den du mit dem Arduino sendest auch mit dem Funkempfänger empfangen ? Also sendet dein Arduinosender auch den eingestellten Code ?

Ich habe mir jetzt doch mal ne Batterie geholt, aber wie gedacht leuchtet da auch die LED die ganze Zeit. Ich denke mal das die Fernbedienung einen weg hat.

Ich habe mir jetzt mal den Spaß erlaubt und meinen 2ten Arduino als Empfänger eingestellt.

Hier die Ausgabe:

Received 1394004 / 24bit Protocol: 1
Received 1394004 / 24bit Protocol: 1
Received 1394004 / 24bit Protocol: 1
Received 1394004 / 24bit Protocol: 1
Received 1394001 / 24bit Protocol: 1
Received 1394001 / 24bit Protocol: 1
Received 1394001 / 24bit Protocol: 1

Also Sender und Empfänger arbeiten korrekt.

Nur leider bekomme ich die Steckdose damit noch nicht angesteuert.

Jetzt muss ich nur die passende Einstellung finden.

Weiß einer wie ich das noch raus bekommen kann???

MFG

Black Zero

Es müsste über die Einstellung der "Mäuseklaviere" gehen. Diese habe ich bisher allerdings noch nicht verwendet, aber da sollte sich etwas im Web finden lassen.

Z.B. dies hier: Dipschalter

Oder Elro als PDF

|500x281

Das ist die Einstellung an meiner Steckdose.

Lauf der Anleitungen soll ich dann:

mySwitch.switchOn("10000", "10000");

  // Wait a second
  delay(1000);
  
  // Switch off
  mySwitch.switchOff("10000", "10000");
  
  // Wait another second
  delay(1000);

Aber leider tut sich da dann gar nichts.

Denke das das irgendwie die falschen Einstellungen sind.

Weiß einer einen Rat???

MFG

Black Zero

blackzero23: Weiß einer einen Rat???

Was hälst du davon, evtl. selbst mal Google zu quälen. ;) Was du uns auch noch mitteilen kannst, welcher Hersteller und Typen von Steckdosen verwendest du ?

Edit: Und dann nochmal die Frage, wieso bist du sicher, dass die Funksteckdosen noch funktionieren ?

Die Steckdosen hatte ich hier noch in Benutzung und seid dem nur im Schrank liegen gehabt.

Die Fernbedienung war unten im Wohnzimmer im Tisch gelagert.

Ich denke mal das den Kids da was ausgelaufen ist und die Fernbedienung deswegen einen weg hat, aber die Steckdosen lagen hier nur rum.

Ich habe Google selber durchsucht aber nichts passendes gefunden außer halt die Links die hier auch gepostet werden oder halt ähnliche Seiten mit dem gleichen Inhalt.

Darum habe ich auch hier nachgefragt, ob einer einen Rat weiß.

MFG

Black Zero

Hast du irgendwo auch ein Bild der Dosen evtl. erkennt die hier jemand wieder. Auch von Dips wäre gut. Gruß DerDani

blackzero23: Darum habe ich auch hier nachgefragt, ob einer einen Rat weiß.

Du solltest wenigstens unsere Frage zur Steckdose beantworten. Volvodani hat es auch geschrieben, Foto der Steckdose und Dipschalter wären auch wichtig.

Hatte ich eigentlich gepostet nur net gesehn das der das nicht anzeigen konnte.

Hier nochmal ein Bild der Steckdose und der Dips:

MFG

Black Zero

Hat die Fernbedienung auch Dipschalter ?

Die sehen eigentlich wie die bekannten (Link) aus, außer es sind nur Zahlen. Du hast schon alle Stellungen getestet ?

Sorry, da fällt mir nichts mehr ein.

Hast du auch das PDF gelesen ? Da stehen wichtige Dinge zum "Hauscode" drin !

blackzero23: Ok, dann bin ich da ja schon ein bischen schlauer.

Normalerweise leuchtet die LED der Fernbedienung immer kurz auf wenn ich eine Taste drücke.

Wenn ich die allerdings an das Netzteil anschließe und es auf 12 Volt stelle, dann leuchtet die LED dauerhaft.

Die Steckdose reagiert weder auf die Fernbedienung noch auf den Sender.

Bei der Fernbedienung bin ich mir nicht sicher wegen dem Netzteil, aber die Steckdosen funktionieren eigentlich einwandfrei.

Ich weiß nur leider nicht wo der Fehler liegt.

MFG

Black Zero

das Problem hatte ich auch bei zwei Fernbedienungen. beide übers netzteil versorgt und...... abgeraucht. warum? keine Ahnung. keine Verpolung oder falsche Spannung. hatten beide die selben Symptome wie bei Deiner.