Gelöst: Problem Arduino Fedora17 USB

Hallo, mein Problem besteht darin, dass mein Arduino 1.0.1 keine USB Schnittstelle erkennt, also bei Serieller Port. Wenn ich mich als su anmelde oder chmod o+rwx /run/lock ausführe geht es, aber es speichert das nicht, denn beim nächsten Einschalten des Rechners, ist wieder kein Port vorhanden. Was mache ich falsch?

Gruß Bernd

Die Lösung: If you run the Arduino IDE as a normal user (you should do that of course), you may get this error message : check_group_uucp(): error testing lock file creation Error details:Permission denied

This is probably because you don't have write permissions on /run/lock directory. Try this to see if this solves your problem : sudo chmod 777 /run/lock

/run/lock is created on boot by /usr/lib/tmpfiles.d/legacy.conf (both on systemd and initscripts). So if you want to keep the permissions you set, simply copy the file /usr/lib/tmpfiles.d/legacy.conf to /etc/tmpfiles.d/ and edit it there (set 0777 permissions).

Hallo beinahe Namensvetter,

ich vermute mal, daß du als Benutzer nicht in der richtigen Gruppe (dialout?) bist und es dir dadurch nicht erlaubt ist serielle Geräte zu benutzen.

Grüßle Bernd

Hallo Bernd,

danke für deine Antwort. Es gibt bei fedora 17 wohl keine dialout Gruppe. Wenn ich ein Terminal öffne und dort als Root chmod 777 /run/lock eingebe, funktioniert alles. Wenn ich mich nur ein und auslogge, geht es auch noch, nur nach einem Rechnerneustart geht es nicht mehr.

oder eine uucp Gruppe?

wenn du nicht weißt, in welcher Gruppe deine serielle Schnittstelle ist, hilft folgendes.

  1. herausfinden, welches Device der Schnittstelle zugeordnet ist. Dazu als root im Terminal vor dem Anstecken des Arduinos folgendes eingeben:
tail -f /var/log/syslog

nach dem Anstecken kann man die Schnittstelle ablesen, in meinem Fall ttyADM0.

Jul 16 20:46:53 reinhard-Predator-G3600 kernel: [ 9168.067835] usb 2-1.7: new full-speed USB device number 4 using ehci_hcd
Jul 16 20:46:53 reinhard-Predator-G3600 mtp-probe: checking bus 2, device 4: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.7"
Jul 16 20:46:53 reinhard-Predator-G3600 mtp-probe: bus: 2, device: 4 was not an MTP device
Jul 16 20:46:53 reinhard-Predator-G3600 kernel: [ 9168.311549] cdc_acm 2-1.7:1.0: ttyACM0: USB ACM device
Jul 16 20:46:53 reinhard-Predator-G3600 kernel: [ 9168.312007] usbcore: registered new interface driver cdc_acm
Jul 16 20:46:53 reinhard-Predator-G3600 kernel: [ 9168.312010] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
  1. folgenden Befehl im Terminal eingeben
ls -l /dev/ttyACM0

Die Ausgabe zeigt die Gruppenzugehörigkeit, hier dialout.

crw-rw---- 1 root dialout 166, 0 Jul 16 20:47 /dev/ttyACM0

in fedora scheint alles anders zu sein:

tail: „/var/log/syslog“ kann nicht zum Lesen geöffnet werden: Datei oder Verzeichnis nicht gefunden

dmesg > tail ergibt

[ 242.381362] usbcore: registered new interface driver ftdi_sio [ 242.381381] USB Serial support registered for FTDI USB Serial Device [ 242.381464] ftdi_sio 2-1.8:1.0: FTDI USB Serial Device converter detected [ 242.381495] usb 2-1.8: Detected FT232RL [ 242.381497] usb 2-1.8: Number of endpoints 2 [ 242.381500] usb 2-1.8: Endpoint 1 MaxPacketSize 64 [ 242.381502] usb 2-1.8: Endpoint 2 MaxPacketSize 64 [ 242.381504] usb 2-1.8: Setting MaxPacketSize 64 [ 242.382069] usb 2-1.8: FTDI USB Serial Device converter now attached to ttyUSB0 [ 242.382082] ftdi_sio: v1.6.0:USB FTDI Serial Converters Driver

also die Schnittstelle ist glaube ich schon klar: ttyUSB0

dann ergibt: ls -l /dev/ttyUSB0

crw-rw----. 1 root dialout 188, 0 16. Jul 21:50 /dev/ttyUSB0

was soll ich da machen???

nur wenn ich: chmod 777 /run/lock eingebe, funktioniert es.

gib mal im Terminal folgendes ein

cat /etc/group

und schau nah, ob du als User in der Gruppe dialout angelegt bist.
Falls nicht, musst du dich hinzufügen. Als root im Terminal

usermod -aG dialout <deinUser>

Diese Änderung beibt bei Neustart bestehen.

Ergebniss:

dialout:x:18:bernd

uucp:x:14:bernd

für heute gebe ich auf, gute Nacht

ich habe hier http://arduino.cc/playground/Linux/Fedora noch eine Anleitung gefunden. Weiter unten im Abschnitt "Install Arduino on Fedora 13 or later" steht, dass der User auch Mitglied der gruppe "lock" sein soll. Check das mal. Leider hab ich kein Fedora und kann das nicht testen.

If you run the Arduino IDE as a normal user (you should do that of course), you may get this error message : check_group_uucp(): error testing lock file creation Error details:Permission denied

This is probably because you don't have write permissions on /run/lock directory. Try this to see if this solves your problem : sudo chmod 777 /run/lock

/run/lock is created on boot by /usr/lib/tmpfiles.d/legacy.conf (both on systemd and initscripts). So if you want to keep the permissions you set, simply copy the file /usr/lib/tmpfiles.d/legacy.conf to /etc/tmpfiles.d/ and edit it there (set 0777 permissions).

allen Helfern vielen Dank Bernd