Genuine Mega2560 no longer detected

I have two genuine Arduino Mega2560 which have always worked fine up until yesterday.

I was messing around with some electronics with one of the Mega and later, when I that very same Mega to upload a different sketch, it was no longer recognized.

On the device manager it appears as an Unrecognized USB Device. When asking device manager to update the driver, it just tells me the best driver is already installed.

image

Plugging the Arduino to a different PC, I get the same result. Changing USB cables doesn't change anything either.

I was thinking I damaged the Arduino, but here's where it gets really weird. I plugged in the other Arduino Mega, which was working fine the last time I used it, and I get the same problem. Once again, changing PCs or cable changes nothing.

Does anyone know how this can be fixed? I've tried burning the boatloader from a chinese Nano clone, but I get a timeout error when uploading the Blink sketch (possibly having to do with the Nano not being genuine).

If anyone knows how I can fix this, I would be really grateful.

Best regards,

Does the good Mega have the same problem on both PCs?

Burning the bootloader can't help with this particular class of problem on the Mega. The reason is that on the Mega the USB capabilities are handled by a dedicated ATmega16U2 microcontroller. If there is a firmware problem on the board causing a USB problem, then it would have to be the firmware on the ATmega16U2. But when you are burning the bootloader, that only affects the firmware on the ATmega2560 microcontroller, and so it has no affect on the ATmega16U2.

There is no difference between a bootloader burned using a derivative/clone/counterfeit Nano and a bootloader burned using a genuine one. You might well have a harder time getting a successful burn bootloader operation with an unofficial Nano, but if you actually manage to have success then you are fine.

It's not clear to me what the circumstances were around this Blink upload though. Did you manage to get a COM port for your Mega finally to upload to? Or are you trying an "Upload using Programmer" via the Nano? Or what?

It's not clear to me what the circumstances were around this Blink upload though. Did you manage to get a COM port for your Mega finally to upload to? Or are you trying an "Upload using Programmer" via the Nano? Or what?
My attempt at uploading the Blink sketch was done using the boatloader via Nano.

Another detail: the bad Mega now warms up a lot on the USB port. It seems something is physically broken inside. On the "good" Mega, this does not happen.

Perhaps it has something to do with the ATmega16U2 firmware. Do you know how to fix firmware problems on this microcontroller?

I'm doubtful the heat will be caused by a firmware problem. That is most likely a hardware problem.

But I'll answer your question anyway because it's interesting information regardless of whether it's actually useful. There is an old but still mostly useful tutorial about replacing the ATmega16U2 firmware here:
https://www.arduino.cc/en/Hacking/DFUProgramming8U2

You can also do it by connecting an ISP programmer to the ICSP header next to the ATmega16U2 on the Mega (it has two ICSP headers, though perhaps only one of them has been populated) and then flashing the firmware binary to the ATmega16U2 via the programmer. The DFU approach described in the tutorial linked above is convenient because it doesn't require a programmer, but it does rely on having the Atmel FLIP software installed.

Another interesting project related to the ATmega16U2 on the Mega and Uno boards:

Thank you for the suggestion.
I've attempted to use bootloader to fix the ATmega16U2 of my second Mega, but I get a strange error: "Expected signature for ATmega16U2 is 1E 94 89".
I also attempted to use bootloader on the ATmega2560 to see if I could write sketches to it. I got the Nano (which I was using as an ISP programmer) to successfully upload a sketch, yet the Mega would not run it.

Eventually I tried measuring the resistance between each Mega's 5V and GND pins with a multimeter. The first Mega had a resistance of 50 Ohm, while the second Mega had a resistance of 48.5 Ohm. For comparison, on my Nano clone I get about 5 kOhm, which seems far more reasonable.

In conclusion, both Megas need to be replaced. What worries me was how the second one started malfunctioning while sitting nicely on my drawer. My theory was the fist Mega did something to the USB port that caused it to damage the second Mega while plugging it immediately after unplugging the first Mega. But even that sounds like a stretch.