Gérer lun lave linge en co-propriété

Bien sûr, une gâche est une inductance.

Tant qu'il s'agit d'un petit module relais avec sa diode de roue libre, pas de problème car la diode absorbe les surtensions.

Regarde les oscillogrammes ici : https://riton-duino.blogspot.com/2018/08/alimenter-un-relais-transistor.html Paragraphe 1.1. La diode de roue libre

Mais à partir du moment où le relais commande une inductance (contacteur, gâche, etc.) sur le 230V, les parasites perturbent le 230V et passent même à travers l'alimentation de l'ARDUINO.

S'agit-il d'une gâche 230V ou 12V continus ? Si c'est une gâche 12V tu peux résoudre avec une diode de roue libre. Si c'est une gâche 230V tu peux résoudre avec un circuit RC ou une varistance.

hbachetti: Bien sûr, une gâche est une inductance.

Tant qu'il s'agit d'un petit module relais avec sa diode de roue libre, pas de problème car la diode absorbe les surtensions.

Regarde les oscillogrammes ici : https://riton-duino.blogspot.com/2018/08/alimenter-un-relais-transistor.html Paragraphe 1.1. La diode de roue libre

Mais à partir du moment où le relais commande une inductance (contacteur, gâche, etc.) sur le 230V, les parasites perturbent le 230V et passent même à travers l'alimentation de l'ARDUINO.

S'agit-il d'une gâche 230V ou 12V continus ? Si c'est une gâche 12V tu peux résoudre avec une diode de roue libre. Si c'est une gâche 230V tu peux résoudre avec un circuit RC ou une varistance.

Merci de ta réponse. c'est une gâche 12V donc si j'ai bien lu sur ton blog j'ai besoin d'une diode 1N4148 pour mon relais 5v ?

Il semble qu' il faille la brancher en parallèle, c'est a dire en dérivation ? Concrétement il faudrait que je la branche sur mon relais coté arduino entre le + et le - non ??

Excuse mon ignorance, mes cours de physique de 4ème sont de plus en plus loin...

Non, je suppose que tu as acheté un module relais, donc déjà équipé d'une diode sur la bobine.

Il faut une diode sur la gâche, en parallèle et à l'envers, l'anode au +12V.

Ah ok, donc je dois la mettre comme sur mon dessin je dois laisser une liaison entre le relais et la gâche, et mettre sur la même borne la diode en parallèle ?

Non, en parallèle sur la gâche.

hbachetti:
Non, je suppose que tu as acheté un module relais, donc déjà équipé d’une diode sur la bobine.

Il faut une diode sur la gâche, en parallèle et à l’envers, l’anode au +12V.

salut hbachetti,

Je me suis procuré les éléments pour les montages mais j’aimerais être sûr de mon installation avant de me lancer, histoire de pas les “fumer”…

Pour la gache électrique est ce que ça donnerait ce schema ?

Pour le lave linge, dont la bobine du télérupteur fait planter l’arduino, j’ai bien vu le schéma pour ton arrosage automatisé mais je ne le comprend pas , tout d’abord

Est ce que je dois mettre la résistance et le condensateur en série ?

Où les situer sur mon installation . Si j’ai bien compris l’intérêt d’un condensateur X2 est d’atténuer l’a-cout du 220v sur le circuit, j’aurais donc tendance à le mettre comme sur le schema…

OK pour la diode.

Le circuit RC doit être en parallèle avec la charge du relais, donc en parallèle sur la bobine du télérupteur. Sur mon schéma le circuit RC est en parallèle avec LOAD. Que le relais coupe la phase ou le neutre importe peu. Le circuit RC doit être monté entre A1 et A2, pas entre le A1 et le relais.

hbachetti: OK pour la diode.

Le circuit RC doit être en parallèle avec la charge du relais, donc en parallèle sur la bobine du télérupteur. Sur mon schéma le circuit RC est en parallèle avec LOAD. Que le relais coupe la phase ou le neutre importe peu. Le circuit RC doit être monté entre A1 et A2, pas entre le A1 et le relais.

La gâche fonctionne à merveille c'était bien ca le problème merci beaucoup de ton aide.

Pour le télérupteur, c'est compris, en parallèle à la bobine, c'est à dire entre A1 et A2; par contre je n'ai pas de polarité sur mon condensateur c'est normal?

2ème question(et dernière normalement) Il faut mettre la résistance avant ou après le condensateur ?? (oui je pars de très loin niveau éléctronique ;D ;D )

La gâche fonctionne à merveille c'était bien ca le problème merci beaucoup de ton aide.

Bonne nouvelle.

Pour le télérupteur, c'est compris, en parallèle à la bobine, c'est à dire entre A1 et A2; par contre je n'ai pas de polarité sur mon condensateur c'est normal?

Un condensateur polypropylène X2 est non polarisé.

2ème question(et dernière normalement) Il faut mettre la résistance avant ou après le condensateur ?? (oui je pars de très loin niveau éléctronique ;D ;D )

Peu importe. Il faudra par contre bien vérifier que les deux fils et les pattes des composants soient bien serrés dans les bornes du télérupteur. Cela risque de ne pas être très évident, vu qu'ils ont des sections très différentes, surtout la résistance.

Il doit être possible de souder les pattes des composants sur un bout de fil électrique et de mettre l'autre bout dans la borne du télérupteur...?

hbachetti: Bonne nouvelle.

Un condensateur polypropylène X2 est non polarisé.

Peu importe. Il faudra par contre bien vérifier que les deux fils et les pattes des composants soient bien serrés dans les bornes du télérupteur. Cela risque de ne pas être très évident, vu qu'ils ont des sections très différentes, surtout la résistance.

Trop fort @hbachetti ! Les 2 fonctionnent très bien c'est une bonne chose !! Reste plus qu'a continuer. Merci beaucoup !

Ps : Par rapport à la problèmatique de différence de section de fils j'ai utilisé des Wago de fils souple (ils acceptent de 0,14 à 4mm2 en souple et 0,2 ou 4mm2 en dur ;) )

Super ! ! !

On va enfin pouvoir entrer dans cette résidence étudiante, ça fait une semaine que je suis coincé devant la porte !!

Et recevoir ta carte de lavage :)

lesept: On va enfin pouvoir entrer dans cette résidence étudiante, ça fait une semaine que je suis coincé devant la porte !!

:D :D :D :D tu aurais du m'appeler je t'aurais ouvert !! :D :D . On est effectivement pas a l'abri de pouvoir ouvrir la porte avec un badge d'ici ces prochains jours, par contre ne resilie pas trop vite ton abonnement au dressing car c'est pas encore gagné pour le lave linge ! ;)

hbachetti: Et recevoir ta carte de lavage :)

il fallait commencer par la gâche car il y a moins d'intérêt à avoir une carte illimitée de lavage si il ne peut pas entrer dans la résidence ;)

Bonjour à tous,

Je dépoussière ce post (et mon ESP32 ) pour essayer de finir ce projet une bonne fois pour toutes et pour que @lesept puisse venir laver son linge si il est toujours sur ce forum ;) .

Pour rappel car ca remonte bien à 6 mois, je n'y connais rien en Arduino,en programmation,en électricité,en électronique, en informatique et j'aimerai gérer le lave linge seche linge d'une résidence étudiante via badge RFID et ESP 32; d'où le besoin de votre aide :).

Je pense ne plus être très loin du but, j'ai même fait le prototype de la console en médium mais il reste quelques problèmes avant de pouvoir l'installer.

A ce jour; j'ai resorti le projet, la décrémentation du nombre de lavages fonctionne, je pouvais faire le changement de badge, l' incrémentation via un site internet local mais j'avais régulièrement des reboot. Je me suis dit que les milliards de tests que j'ai effectués sur mon ESP32 l'avaient peut être fatigué donc j'en ai acheté un autre.

C'est un ESP32 WROOM32 Comme celui d'origine, le problème est que lorsque je télécharge, il fini le téléchargement, ne se connecte pas au wifi et me met une erreure de type

E (6203) SPIFFS: mount failed, -10025
An Error has occurred while mounting SPIFFS

alors qu'avec le code fonctionne très bien avec mon premier ESP32 WROOM32 ??

Vous voyez une raison pour que cela marche avec un ESP 32 et pas l'autre ??

Merci d avance.

Salut

Quel partitionement de la mémoire flash avez vous retenu (dans le menu la où vous choisissez la carte)

Salut J-M-L

Celui par défaut : Default 4MB with spiffs (1,2MB APP/1,5MB SPIFFS)

Et vous avez chargé les fichiers dedans depuis l’interface ?