getting launch4j error trying to open arduino ide desperately need help

im so tired of spending hours online trying to fix such a stupid issue. ive been trying to open arduino so i can write a sketch and it keeps giving me error launch4j unable to open the program.

  1. ive tried reinstalling 2.ive tried updating java 3.ive tried running as admin 4.ive tried deleting java off my computer entirely 5.ive tried turning off my bluetooth drivers and wifi drivers 6.ive tried having my arduino mega 2560 plugged in and unplluged when starting the program

nothing is working and every fix ive found on the web doesnt do shit. this is getting beyond irritating wasting 5 hours sitting here wanting to throw my tablet through my french door windows. The program was working awhile back and due to some kind of updates or something, it doesnt work now. this is why i hate updates because they always fuck shit up no matter what the company is.

for the love of god please someone help me to get my ide working again