Getting Started with Arduino

I am going into retirement and love programming so bought a HP laptop (windows 10) and an Ardiuno UNO to automate the house. When I first loaded the software and installed the UNO it had no com ports so I came here and read most posts trying most of them. I read the moderators post about other people solving my problems so have tried for the last week to sort the issues with everything google could tell me. Tried loading the Arduino.inf file but windows thinks it knows better and wont let me use it. I am at my wits end. I am not asking for the answer but a place to start would be helpful.

Do you see a new device appear in Device Manager after you plug your Nano into your computer using the USB cable?

I just started from scratch. No new devices appeared in the device manager. I tried both ends of the cable in case of any loops and also tried it with the Arduino system running and without.
I looked at the Com 3 port properties, resources tab, and it says “this device isn’t using any resources because it has a problem”. I also tried all 3 USB ports including one I know works, cause it is where I have the mouse plugged in.

Is it a genuine UNO or Chinese copy - some require additional drivers.
Are you using a data type USB lead - charger leads do t have all the data connections.

Downloaded Arduino IDE from the Arduino web site ?

I looked at the Com 3 port properties, resources tab, and it says “this device isn’t using any resources because it has a problem”.

Does COM3 only appear when you have the Uno connected to your computer?

Hammy it is a genuine UNO and data cable from Jaycar and downloaded it from I believe the UNO is working and it is more a computer problem.
Pert, The COM3 port is there all the time. I had to add the COM & LPT by using “Add Legacy” function.
I will try the startingelectronics link and let you know how I go.

My suggestions:
Try the Uno with another computer and another USB cable. Perhaps you can use a friend's computer for a few minutes, just to see if the COM port shows up. It should show up in device manager when you connect the UNO and disappear when you disconnect the computer. If it does not work, perhaps you got a bad one.

I think you have something very basic wrong going on. I don't normally use an Arduino on Windows, but I went ahead and walked up to my Windows 10 machine and looked at device manager. Here is before I plugged in my UNO.

Here is after I plugged in the UNO.

COM4 disappeared when I unplugged the UNO. Then I plugged it back in a different port, and COM4 appeared again. I think it depends on what other sorts of things you have plugged in, that will determine what COM number you get when you add the next one, like adding an UNO. Anyway, I right clicked COM4 and went to properties, then went to the Details tab.

Then looked at the Events tab.

That's an UNO.

See if you can get something like that to happen with some cable on some computer.

Pert, The COM3 port is there all the time.

Then forget about COM3 because it’s not your Uno.

Thank you all, I used a bit of information from all of you and believe it was the Arduino board. Took it to a Jaycar store and tried it in store to find the board was not talking to the computer. They replaced it and wow here I go. Already designing a stop light for my sons garage cause he has run into the wall ready (not much room between wall and door closing behind the car). Will use the auto garage door opener to enable the stop light. The world is at our feet.

I'm glad you have a working board now and are already having fun with it. Enjoy!