Getting the IDE source to run in Eclipse

Dear community,

I would like to contribute my two cents to the Arduino IDE development but it seems that I cant get the source to run in Eclipse. I have good knowledge in Objective C, C# and of course the Arduino language but I’ve never worked in Eclipse or Java.

I was able to import the source into a new workspace and my run configuration settings are as follows:
Project: processing-head
Main-Class: processing.app.Base

I get the following errors:

1 ---- Project 'processing-head' is missing required Java project: 'processing-core
2 ---- The project cannot be built until build path errors are resolved

Furthermore if I proceed running ignoring the error give me:

"The project: processing-core which is referenced by the classpath, does not exist."

So it seems that I need to include/import the “processing-core” into the project.

So my questions are:

  • Is there any tutorial out there where I can find the steps needed to get the source to run in Eclipse?
  • Where can I download the “processing-core” library?
  • How can I add the “processing-core” library in Eclipse to the project?

Best wishes and thanks in advance,
Marius

Okay... after a few hours of searching the web I got the error to disappear... now I ran into a new error:

Exception in thread "main" java.lang.NullPointerException
    at processing.app.I18n._(I18n.java:51)
    at processing.app.Preferences.init(Preferences.java:211)
    at processing.app.Base.main(Base.java:117)

I got into the source at "processing.app.l18n" and as a comment it says there "... might be a null pointer exception... "

...

static protected void init (String language) {
    // there might be a null pointer exception ... most likely will never happen but the jvm gets mad
    try {
      if (language != null && language.trim().length() > 0) {
        Locale.setDefault(new Locale(language));
      }

....

I havent modified anything in code yet.

I downloaded the latest Arduino source 1.0.6 from GitHub: https://github.com/arduino/Arduino/tree/1.0.6

Any ideas? :~

I can't advise on the Eclipse issues, but I would strongly suggest using the ide-1.5.x branch. While 1.0.x is still a maintained stable branch, new development is going into 1.5.x.