Going "downgrade" from IDE rev 1.6.5 to IDE 1.6.11

Hi for quite long time I worked with IDE1.6.5 Beta version. I have noticed 1.6.5 is not supported anymore so I installed the released 1.6.11. Here the problems came. All old programs do not run. So far experience 2 problems:

  1. Warning problem: " fail to open sketch:"c:xxx\ filename.ino"

  2. Problems with the: "LiquidCrystal_I2C" , only partial information displayed on the LCD 16x2

I replaced boards and boards type, lcd's I tried to load new program with the 1.6.11 and copy the downgraded files with no help....

does anybody experience such problems (xxx.ino and lcd libraries compatibility?) Thanks

meirbns: 2. Problems with the: "LiquidCrystal_I2C" , only partial information displayed on the LCD 16x2

Try updating to the latest version of that library. There has been a change in the way the Arduino core's Print library works which has broken old versions of LiquidCrystal_I2C library. See https://github.com/arduino/Arduino/issues/4142 and https://github.com/marcoschwartz/LiquidCrystal_I2C/pull/5 for more information. It's also possible if you're using a poorly maintained version of the library that the issue has not been fixed.

Dear Pert, Thanks for your reply.

I updated the core print.ccp with no help. Neither the LiquidCrystal_I2C.ccp as suggested in the links. I believe the problem is with the IDE1.6.11 .

The only solution which solved the problem was to go back to rev 1.6.5. this solve both the: " fail to open sketch:"c:xxx...\ filename.ino" and the 'LCD' problems without changing the core files.

Many thanks .

I don't recommend modifying Print.cpp, it was changed for a reason and a lot of thought and discussion went into that change. Any modifications you make will be reverted the next time you update to a new version of the core for your board(or IDE if it's an Arduino AVR Board).

I haven't used the marcoschwartz library but I have extensively used https://github.com/fdebrabander/Arduino-LiquidCrystal-I2C-library with no problems.

As for fail to open sketch:"c:xxx...\ filename.ino", I'd need more information to look into that but it sounds like you're happy with 1.6.5 for now. That was a good version even if it's getting a bit old now.