GPRS shield 2.3

Hi, I bought Arduino Yun and this shield http://www.arduinotech.cz/produkt/ethernet-shield-w5100-626/

My problem is when I turn gsm shield on, it turn off after 3s.
Video: - YouTube

Any idea how to solve this problem and what is causing it? Btw I think I got actually gprs v1.3
But under shield is written 2.3. But there is no sign of existence on Google.

Thanks.

Do you have a separate power supply for the shield? One big enough to supply the current it needs when trying to connect to the network?

Ok now it's stable with additional power.. But seems not finding network by datasheet it's flashing every second

Ps: power 1A

Edit: tried 2.1A iPad charger device for 1 min still same blinking

I’m assuming you have a sim card in? :wink:

If it doesn’t connect in 10 - 20 seconds and you have tried it in different locations then all I can suggest is trying a different network. I have pay-as-you-go sim cards for the three major networks in my country and swap them over as necessary.

Yes SIM is in :slight_smile:

Currently I don't have access to another operator SIM. I let u know result after I get it.

Edit: one more question.. Serial ready at commands should be printed after connection to network? I can't see any AT in debug

Czech isn't my strongest language :wink: so I can't glean much information from the page, nor is it a shield that I'm familiar with. However, I assume that you can configure it to use pins 7 & 8. If so, try the basic SerialRelay sketch to be found on the page linked to in my signature. You need to send the AT commands in capital letters with some SIM900 configurations.

I got this code: http://pastebin.com/AMgvVZDe (wrotten all by me)

D7 (RX) - GSM shield is connected to Yun 9
D8 (TX) - GSM shield is connected to Yun 8