GPS not responding to $PSRF1xx commands

Hi,

I have a USGlobalStat EM-402 GPS. It uses the SiRFStarII chipset (http://www.sparkfun.com/commerce/product_info.php?products_id=576). It's spewing out so much data that it's overwhelming my arduino's software serial port. I'm trying to throttle back the amount of data that it's sending using the $PSRF1xx commands from the NMEA protocol.

But... it's ignoring me. I've tried putting it into debug mode, but it ignores that too. :( I have the GPS connected to the USB to serial converter used to program a lillypad. I can see the NMEA sentences fine. What am I doing wrong?!?!?

Here are the commands I'm trying to send:

$PSRF103,00,00,05,00*20 $PSRF103,01,00,10,00*25 $PSRF103,02,00,10,00*26 $PSRF103,03,00,10,00*27 $PSRF103,04,00,10,00*20 $PSRF103,05,00,10,00*21

And here's the command to turn debug on that I'm trying:

$PSRF105,1*3E

Any help at all would be appreciated! :D Jules.

anyone? beauler?

Check your checksum, (I'm too lazy to do it for you) as i have found that this is the most common reason for commands not being accepted.

I haven't tried this on arduino BUT when I try and use a GPS I have to have a CR and LF at the end of each request

"$PSRF103,00,00,00,01*24",CR,LF 'GGA "$PSRF103,01,00,00,01*25",CR,LF 'GLL "$PSRF103,02,00,00,01*26",CR,LF 'GSA "$PSRF103,03,00,00,01*27",CR,LF 'GSV "$PSRF103,04,00,00,01*20",CR,LF 'RMC "$PSRF103,05,00,00,01*21",CR,LF

hope this helps