Graph Tutorial - Problem with Processing?

Hi All,

I'm running through some of the tutorials and have got stuck on the Graph tutorial, the code for which can be found here: http://arduino.cc/en/Tutorial/Graph

I am using an Uno on Arduino 1.0.3, Processing 2.0.1 and Windows 7.

  • I have set up a potentiometer on my breadboard according to the diagram and have used the serial monitor to check that my set-up is reading A0 properly.
  • I've downloaded Processing and have configured it as recommended in the tutorial.
  • I've uploaded the StandardFirmata sketch to the Uno.
  • I've run the Processing code from the tutorial and it starts to run.
  • The graph window opens, but just sits there with a black background.

The confusing thing is that it worked first time for me (i.e. started plotting a graph) yesterday, but when I went back to play around with the code today, it didn't work and hasn't worked since! I'm wondering whether it might be a problem associated with Java as when I tried to repeat the process today, it asked me if I wanted Java to be able to access the web... and I said that it could.

Any thoughts?

Many thanks,

Tom

Speaking with a colleague, I have now found an answer to this problem.

I had been following the instructions on the playground wiki (http://playground.arduino.cc/Interfacing/Processing).

I had been uploading the StandardFirmata sketch to the Uno and running the code in Processing (as per the instructions). However, it would appear that this was incorrect and that I should have been running the Graph sketch on the Uno - don't know whether this is specific to this example or a general comment.

Either way - this is now closed.