Graphical glitches in Windows 7

Hello. I just downloaded Arduino 1.0, and I noticed this weird graphical glitches: http://screenshu.com/static/uploads/temporary/ju/g9/8j/br9i5d.jpg I've read that this might be caused by outdated java included with the Arduino app. I've removed java folder from Arduino directory, but it wouldn't start. So I copied java folder from my "Program Files", but the glitch still persists. I tried couple of version of java, jre6, jre7, jdk, and even 64-bit versions of them (Arduino wouldn't run with 64-bit binaries at all). My drivers are updated, so they can't be causing it. I'm running Windows 7 x64.

Hello.

I have a similar computer (Arduino 1.0, Windows 7, 64 bit; high resolution display) that does not have the problem. The most significant difference between your computer and mine is very likely the display adapter and driver.

I suggest testing with: hardware acceleration disabled; lower resolution; safe mode. If any of those work I wish you the best of luck with the display adapter vendor. If none of those work report back. Someone else may have suggestions.

I get some of that (not nearly as bad) on my bench machine in linux, its some old onboard ATI thing using the generic linux drivers, so I just blamed it on that, but its interesting I am not the only one, and its appearing in a different OS (though its java so that really doesnt matter)

just wondering what kind of video card do you have?

Nvidia 560GTX-Ti Hawk. Newest drivers, and I haven't had any problems with graphics in any other app.

BUMP

I tried everything, it's really annoying :/ Most of the time I can't even see the code...

The problem persists in safe mode?

It doesn't actually, but that doesn't help me in solving my probem