Grbl and nema 23 very strange issue

hey everyone
i have this issue that I did my absolute best to fix but with no luck,

I have a DIY cnc with cnc shield and nema 23 , the nema 23 stepper driver is tb6600

i control the cnc using inevitables easel.

here is my issue , what ever grbl settings I use , the cutting will always scale down
for example, my bed is 450x450mm
when I want to cut a 10mm x10mm square, it will only cut 2mmx2mm square
I changed the feed rate and step/mm settings my results changed from 10x10mm square to 14x14mm square , however if I add too much value the stepper will lose its mind and start spinning in place, I tried making accurate steps/mm and correct feed rate, but still same issue

note: before I used ramps 1.4 and everything works perfectly , I tried same settings still no luck
any possible help?

Sounds like the motor is miss-stepping - try dialing down the acceleration and max speed settings - perhaps your new setup has a different microstepping factor that you forgot to account for?