GRBL et G-Code

Bonjour,

Je procède aux premiers tests de ma carte http://blog.protoneer.co.nz/arduino-cnc-shield/ et je rencontre une petite difficulté avec le test des moteurs. Après avoir trouvé non sans mal (pas de doc sur le sujet) le sens de connexion des moteurs NEMA17 (Vert / Noir / Rouge / Bleu), je lance la commande pour faire tourner les moteurs (G90 puis G00 Y100.0 F400). Tout se passe bien la première fois. Mais je suis dans l'impossibilité de faire tourner de nouveau le même moteur! Je suppose qu'il y a des instructions G-Code qui doivent débloquer la situation... J'ai trouvé ce lien http://robert.cireddu.free.fr/Ressources/Prod/Codes_ISO/index/index.htm, mais dans cette jungle d'instructions, je suis un peu perdu!

Ma configuration de test : * ADUINO DUEMILANOVE * Carte protoneer * grbl 0.9d * moteur NEMA 17 * Alimentation de puissance : transfo 12V 2A * Window Vista * IDE 1.0.5

Vos conseils sont les biens venus. Olivier

Bonjour,

Bernardino: je lance la commande pour faire tourner les moteurs (G90 puis G00 Y100.0 F400). Tout se passe bien la première fois. Mais je suis dans l'impossibilité de faire tourner de nouveau le même moteur!

Si tu est en mode absolu et que tu renvoies la même commande c'est normal puisque le moteur est déjà dans la position voulue. As-tu fait des essai en mode relatif ? Transmets-nous la séquence GCODE qui suit G90 puis G00 Y100.0 F40. @+

Effectivement, lorsqu'on lit la documentation, on trouve l'explication. De plus en testant avec GRBL Controller, on voit la commande G91.

En tout cas, je n'avais pas pensé au mode absolu/relatif.

Merci de m'avoir ouvert les yeux! Olivier