Grbl et l'ide Arduino

c'était ce fichier https://github.com/zapmaker/GrblHoming/blob/master/trlocale/GrblController_fr.ts mais je ne retrouve pas mes modifs, et github, j'en suis a la découverte pour retrouver des modifs faites. :(

@infobarquee, pour modifier il faut les droits d'écriture !!

oui, les modifs avaient été prises en compte dans un autre fichier montrant les différences pendant 2 jours. et puis plus rien.

Bonjour, sur mon site https://github.com/LETARTARE/GrblHoming/tree/Letartare je vous propose une version 'GrblController-3.6.1-T1,' qui permet de détecter deux versions 3 axes et 4 axes correctement (0.8c et 0.8c1 qui devrait arriver aujourd'hui) et visualise ,lors de l'envoi d'un fichier sur la carte, les numéros de lignes du fichier, s'il n'en existent pas.

A bientôt.

Bonjour, sur mon site https://github.com/LETARTARE/Grbl-xx_with_Arduino/tree/master/Grbl8c1Mega2560, voici enfin la '0.8c1', une version quatre axes de la version officielle '0.8c'. Attention au brochage qui est semblable, en partie, à la '0.845' qui risque de devenir obsolète.

Pour GC-3.6.1-T1, je n'ai fourni que les sources avec des fichiers de fabrication pour 'Win32' ; mais je crois qu'avec le fichier *.pro on doit pouvoir l'utiliser sous Linux si la bibliothèque 'Qt-4.?.?' est installée. Pour 'VISTA pro' j'ai installé 'Qt-4.7.3' et 'MINGW32-TDM-4.7.1".

Bon tests.

Bonour, voici la version Grbl '0.8c2' avec un brochage (différent de la '0.8c1') étendant celui de la '0.8c' au 4ème axe. https://github.com/LETARTARE/Grbl-xx_with_Arduino/tree/master/Grbl8c2Mega2560 . Notez une petite correction sur 'GC-3.6.1-T1' pour une commande manuelle qui générait toujours des valeurs négatives !

A bientôt.

je viens de faire un flash du dernier firmware, mais un truc me chiffonne un peu par rapport aux autres versions. on a plus l'affichage des paramètres au boot, ou alors j'ai pas percuté sur un truc.

Bonjour, non cela est normal, car à force de faire de nombreux essais, l'affichage complet des paramètres est plutôt une pollution. Aussi je l'ai momentanément enlevé de 'GC-3.6.1-T1' et réduit dans '0.8cx'; vous devez avoir ceci :

Mega2560 with 4 axes (X, Y, Z, A)
Grbl 0.8c2 ['

Les commandes "$" et "$$" vont fournir tout le nécessaire.

Bon courage. for help] ```

Les commandes "$" et "$$" vont fournir tout le nécessaire.

Bon courage.

j'avais vu ceci par contre bug génant si on rentre une commande non reconnue, ca fait planter. ex : $x=200 Grbl error: Unsupported statement

c'est l'officielle '0.8c' qui génère ce message !!

c'est bien la tienne, celle que tu as mentionné au dessus 8c2mega2560

je m'explique : la mienne '0.8c2' est une adaptation de la version officielle '0.8c' et c'est la partie officielle qui génère ce message et heureusement car cela montre que l'analyse syntaxique et lexicographique fonctionne correctement.

je vais pas prendre une verveine à cette heure ci :) ou aller me coucher si je veux changer les pas de chaque axe comme sur l'autre, $0=200 pour l'axe X ca mesort une erreur, c'est ca que je voulais dire.

j'ai aussi changé dans le fichier default.h le nombre de pas, masi cela me ressort toujours

$0=100.000 (x, step/mm)
$1=100.000 (y, step/mm)
$2=100.000 (z, step/mm)
$3=100.000 (t, step/deg.)

Bonsoir,
je viens de faire le test suivant ( en regardant la finale du double en Tennis à Roland Garros :))

  • ‘GC-3.6.1-T1’
  • Grbl ‘0.8c2’
    $0=120 → cela est pris en compte correctement.
    J’ai ajouté justement une possibilité de toujours recharger (ou non) les valeurs par défaut dans la carte dans
'config.h:L47'  #define ALWAYS_DEFAULTS_SETTINGS  1  // update always

D’autre part, je constate que sur la version 3.6.1-T1 ( contrairement à ce que j’ai dit dans un message précédent ou je confondais avec la T2 ou T3), on donne la configuration d’emblée par “$$”.
Je joins une photo pour le premier test.

avec une modification du fichier ‘default.h:L87’ → #define USER_PITCH_SCREW 5 // 4mm for all linear axes
voici le résultat :

ben il doit y avoir un schilmblick quelque part, car dans l'ide si je rentre $0 = 120 pas de ok en echo et si j'appuie sur entrée a nouveau j'ai Grbl error: Bad number format

Rebonsoir, est-ce bien avec GC-3.6.1-T1 que vous piloter la carte et non pas avec Arduino-105xx, car avec ce dernier j'ai aussi quelques soucis que je ne comprends pas ?

c'est avec l'ide que je fais les tests et non avec GC-3.6.1-T1 plus qu'a compiler GC-3.6.1-T1 :(

@infobarquee, pour Arduino-105 je viens de vérifier, effectivement aucun dialogue sérieux n'est réalisable même avec la version officielle '0.8c', je pense que le problème pourrait venir de la dernière (ou avant dernière ?) machine 'Java Runtime 7' (1.7.0-55-b14) actualisée sur ma machine le 15-05-2014, car jusqu'au 25 avril 2014 je n'avais aucun problème avec cet outil. Mais je vais faire d'autres tests pour déterminer le problème.

Pour le 'GC-3.6.1-T1', je donnais l'adresse ici le 02 juin 2014 :astonished: https://github.com/LETARTARE/GrblHoming/tree/Letartare La construction pour 'Win32' est expliquée dans 'BuildWin.txt'.

Bon courage.

loic@loic:~$ java -version
java version “1.7.0_45”
Java™ SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot™ 64-Bit Server VM (build 24.45-b08, mixed mode)

je sais plus quand je l’ai mis a jour, mais avant cela fonctionnait.

merci je vois ca dans la journée, dépannage en urgence a faire chez un client :frowning: