Grove - Multichannel Gas Sensor + mkr wan 1300 or mkr wifi 1010

Hey everyone! I have this problem that with the mkr arduinos and multichanel gas sensor - When i upload the grove library example for this sensor, the serial monitor shows nothing at all...I dont know whats the deal with that...:confused: can anyone help?

I am using:

1)library - GitHub - Seeed-Studio/Mutichannel_Gas_Sensor: This Arduino library is used for driving "Xadow - Mutichannel Gas Sensor" and "Grove - Mutichanel Gas Sensor"

2)arduino - 1)Arduino MKR WAN 1300 (LoRa® connectivity) — Arduino Official Store;
2)Arduino MKR WiFi 1010 — Arduino Official Store

3)sensor - Grove - Multichannel Gas Sensor - Seeed Wiki

4)sketch - ReadSensorValue_Grove - from the library

5)pins - scl -> scl
sda - >sda
vcc -> vcc(~3.3)
gnd -> gnd

*Scanning for addresses works and I have found the right address 0x10;
*The sensor works ok with other boards like nodeMcu and Arduino uno on 3.3v and 5v, I can change the sensors address but it doesnt change anything...

*Scanning for addresses works and I have found the right address 0x10;

According to the library examples, the default address is 0x04. So why do you think everything is OK if you get 0x10?

Have you change the Serial object to USBSerial in the example code (as I guess you connected your PC by the internal USB connection and not using an USB2Serial adapter on the hardware serial interface)?

Yea I have changed the address to 0x10...so that should be ok, even when I put it back to 0x04 it doesnt work... ahmm...

Yes the arduino is connected through the main usb port on the device... Can you please give me an example what should I change in the code...as I understand I have to replace Serial - with - USBSerial, but it doesnt recognize USBSerial :confused:

USBSerial is only a thing on the Zero-type SAMD boards. On the MKR boards, the USB CDC port is named Serial, so the example is correct as written.

Please add the following line to the top of the setup function in the example sketch:

while(!Serial) {}

then upload the example to your MKR WAN 1300.

This will cause the operation of the program to wait at that line until you open the Serial Monitor. So hopefully at the very least you should see "power on!" printed.

pert:
This will cause the operation of the program to wait at that line until you open the Serial Monitor. So hopefully at the very least you should see "power on!" printed.

Yes that is exactly what happens...there is a "power on" in the serial monitor and thats all.

OK, at least this tells us that serial communication is working correctly.

I connected the gnd and vcc of the sensor to mkr wan 1300 and the scl sda to arduino uno, ran the example on the uno and everything works on the arduino uno side so the power is not the problem...then I switched it up, gnd and vcc on the uno and scl sda on mkr, on the mkr side still nothing...

Than i tried to connect another grove sensor that uses the scl and sda connection to the mkr wan using the same wires and everything, just switching out the sensor and everything works :confused: