GSM examples give compilation error in 1.0.6

A year ago I bought the SMS shield from Arduino. It has been working well. But now I made some minor changes and didn't understand why I got so many compilation errors! Changed from 1.0.5 to 1.0.6!

Now even the basic examples available from the Arduino examples page go wrong.

"GSM3ShieldV1ModemVerification.cpp:72: error: conversion from 'int' to 'String' is ambigious"

This is just one of the errors.

Does anybody have a clue how I can fix this?

Revert to using 1.0.5? Any reason you need to use 1.0.6?

Of course, 1.0.5-r2 works fine. I just degraded my software pack. I've been working with computers too long, so I routinely upgraded to the newest version. Thanks a lot!! ;D