GSM Shield problem

Hi.

I'am trying to test sending SMS with GSM shield, but it not work. This i only what i get and then it stops.

SMS Messages Sender
AT%13%
0 9>AT%13%%13%%10%OK%13%%10%
AT+CPIN=0000%13%
9 44>AT+CPIN=0000%13%%13%%10%+CPIN: READY%13%%10%%13%%10%OK%13%%10%
AT+CGREG?%13%
44 89>AT+CGREG?%13%%13%%10%+CGREG: 0,2%13%%10%%13%%10%OK%13%%10%%13%%10%Call Ready%13%%10%
AT+CGREG?%13%
89 120>AT+CGREG?%13%%13%%10%+CGREG: 0,2%13%%10%%13%%10%OK%13%%10%
AT+CGREG?%13%

Does anyone know what is the problem? Board is Uno R3 and shield is model GSM R3. Example code is from here https://www.arduino.cc/en/Guide/ArduinoGSMShield

How do you power the shield?

Now it takes power from computer USB.

That's not enough - you need a source that can deliver up to 2amps peak - 1 amp usually OK

Your USB is likely capped at 500mA

If you read the link you provided they say

To upload sketches to the board, connect it to your computer with a USB cable and upload your sketch with the Arduino IDE. Once the sketch has been uploaded, you can disconnect the board from your computer and power it with an external power supply.

And if you look at the board description they explicitly mention

Power
It is recommended that the board be powered with an external power supply that can provide between 700mA and 1000mA. Powering an Arduino and the GSM shield 2 from a USB connection is not recommended, as USB cannot provide the required current for when the modem is in heavy use.

Try with a different power supply

Thanks. Now i put a 1A power to the board and everything works fine.

Good :slight_smile:

Have fun!!