GSM Shield Quetec M10 Many Issues

OK,
Let me try to explain what has happened. I am using GSM Web Client sample. When I first got this board, I was able to connect and everything worked great. I am using Arduino uno with this board and am having major hanging issues. I have searched this forum and the web for fixes and have tried everything i can find but can not seem to get it to work after 97 minutes which has been my best run yet in debug mode. Will not work in regular mode more than 10 minutes.

My Situation:
I am in an area with no signal. This is fine as I simply want to check for a signal, then if it can not connect continue running my program. I have set the timeouts, I have increased the voltage I have changed settings in the libraries but nothing runs solid. Now after attempting to run from a 12v source through vin, I can no longer simply run from the barrel plug. I have run a simple LED run between connections so I can visually see when the connection attempt is. Every 10 seconds, I am attempting to connect to the network, if it fails I run the LED's again for 10 seconds and so on. This was working last night for about 20 minutes before it hung. Now the LED's will not even light unless I hook up the USB with the barrel connector.

Question:
Is this shield just buggy? I am hesitant to use it in the field when it will not run in the lab. Is it because I am not able to connect or am trying to connect so often? Why is my power not working the same today, did I fry something? Am I hanging due to being in test mode? I have spent weeks trying to get this to run with no solid runs. Is this board reliable or am I chasing my tail here?

Here is some of what I have tried as well as others:

Please any thoughts would be welcome.

Ande,

I am on the same situtation. Unfortunatelly after weeks of searching didn't get any reply from the forum at all to any posts of mine! So I supposed that this shield is buggy and there no solution yet.

Here are some of my posts

If anyone have a solution, please let us know

That sounds like a network issue... Although I am not positive. But, that is what I would try first.

What GSM service are you using? Does it come with any troubleshooting tools that might help you reset the device registration on the network? If so, try that.

If not, I recommend getting different service that does come with such free management tools. Neo sims are designed for IoT projects! Here are the benefits I like most:

  • great coverage because it leverages 3 major carriers for cell tower use
  • free device management tool for troubleshooting, alerts, reports, etc.
  • relatively affordable as far as sims and connectivity go. You pay as you go so you'll likely save money and won't have to reload/add more data to the sim.

Here is a shortened link for you: M2M & IoT SIM Card Self-Service Connectivity | Neo™ by Aeris

Hope this might provide some hope for this issue in the future!