h bridge a mosfet

ciao,

eccomi che arrivo speranzoso per una nuova impresa vorrei fare un h bridge a mos. ok fin qui pochi problemi ( si fa per dire) ho comprato mos sia di tipo p che n volendo provare a farlo classico.

mi sono imbattuto in un problema praticamente subito: per evitare di far fischiare i motori vorrei pilotarlo a 20khz in pwm ma ahimè le capacità di gate mi richiedono correnti di commutazione troppo alte.

quindi mi rivolgo a voi nella ricerca di un driver che non sia troppo complesso da interfacciare ai mos il ponte può essere sia misto (canali p-n) sia solo n.

fin ora le ricerche mi hanno orientato su questi:

ir2111 tc4424 irs2304

altre proposte? uno da consigliare tra quelli?

dalla mia ignoranza chiedo: non puoi usare dei transistor che pilotano i mosfet?

volendo si può fare in teoria devo dare correnti dell'ordine di A per ns, ma ci sono questi integrati che lo fanno internamente e sono concepiti per lo scopo

Ma devi per forza farli con dei Transitori singoli e non prendere un integrato giá pronto? consiglerei dei IGBT. Ciao Uwe

ho bisogno di 20A continui e 60V, roba già pronta a un prezzo "normale" non l'ho trovata..

garinus: ho bisogno di 20A continui e 60V, roba già pronta a un prezzo "normale" non l'ho trovata..

Dipende da cosa intendi con prezzo normale, comunque scordati di autocostruirti un ponte H con queste caratteristiche.

e perché? se lo comandassi a basse frequenze non ci sarebbero problemi se non un brusio tremendo da parte dei motori...

garinus: e perché? se lo comandassi a basse frequenze non ci sarebbero problemi se non un brusio tremendo da parte dei motori...

ROTFL.

Ti consiglio di documentarti bene sulla cosa, scoprirai che esistono migliaia di pagine di teoria su questo argomento, è una cosa molto più complessa di quello che sembra e che richiede molto studio, l'approccio da smanettone ti porta solo a fare una enorme frittura di mospower.

ok la frittura di mos non mi preoccupa ormai è all'ordine del giorno XD

visto che mi smontate così cosa mi consigliate nel caso in questione?

garinus: visto che mi smontate così cosa mi consigliate nel caso in questione?

Il grosso problema sono i 60V, sicuro che ti serve tutta questa tensione ?

i motori sono a 48v per stare tranquillo con batterie cariche mi tenevo su una tensione di 60v

ho fatto uno schema di massima senza driver con solo dei transistor a pilotare i mos allegati sia .asc(ltspice) che schema e simulazione a 500hz

EDIT:
i mos nello schema sembrano strani ma sono i più simili a quelli che ho che c’erano in catalogo
EDIT2:
modificato schema non si spegneva mai :wink:

h_bridge.asc (3.71 KB)

http://www.watterott.com/index.php?page=product&x752c6=e89ff253a33f339aabd146abb9a30c7c&info=1795 solo che é per 50V percui per 36V Batterie. Ciao Uwe

a parte il fischio che è uno svantaggio notevole, però ha un suo perché (applico il sistema apple e lo faccio diventare una feature)

il pilotare a frequenza di 500 hz mi migliora il rendimento del motore rispetto al pilotaggio a 20khz, giusto?

garinus: il pilotare a frequenza di 500 hz mi migliora il rendimento del motore rispetto al pilotaggio a 20khz, giusto?

Assolutamente no, anzi è esattamente l'opposto, il pwm dovrebbe sempre essere la più alta frequenza possibile compatibilmente con le caratteristiche del ponte e del motore. Piccolo dettaglio aggiuntivo, i picchi di corrente, anche diverse centinia di mA, per caricare le capacità parassite del gate di un mospower sono sempre gli stessi indipendentemente dalla frequenza di attivazione. Nel caso di mospower per alte correnti, come nel tuo caso, farli funzionare anche per brevi periodi nella zona lineare (corrente di carica non sufficiente) vuol dire distruggerli in breve tempo o comunque sprecare molta potenza in calore invece che utilizzarla come forza motrice. Purtroppo con tensione lavoro di 60V e quelli corrente devi andare sugli azionamenti industriali, quelli che trovi nel settore amatoriale al massimo arrivano a 30V, con costi non inferiori a 150-180 Euro per singolo ponte, ovviamente parliamo di acquisti per singoli pezzi perché se ne compri qualche centinaio costano molto di meno. Se come tensione ti bastano 30V ci sono molte soluzioni a basso costo, p.e. questo, solo 150$, è un doppio ponte 25Ax2 (45A di picco per 5 secondi), si controlla tramite due segnali PPM (servo) e gestisce lui sia il PWM ad alta frequenza che la modalità sterzo se necessario. Volendo c'è questo che tiene i 60V, è un progetto open source al quale ho collaborato durante le sue fasi iniziali, è un buon prodotto italiano con tanto di supporto tecnico, però non lo puoi usare con Arduino perché richiede il controllo in modalità LAP che l'ATmega 328 non supporta, però si può risolvere facilmente interponendo un micro che controlli tramite PPM e lui genera i due PWM, a doppio canale in controfase, ad alta frequenza adatto al controllo del ponte, disponibile il feedback corrente utile per limitare l'assorbimento massimo ed evitare di friggere il motore o il ponte.

Questo scrivono che non é piú disponibile. (ma significa che non lo avranno piú o non lo hanno temporaneamente visto che offrono il servizio di avviso qando disponibile?) Ciao Uwe

uwefed: scrivono che non é piú disponibile.

Vuol dire che è momentaneamente indisponibile, probabilmente gli mancano i mospower adatti ai 60V visto che la versione a 36V è disponibile, la differenza è solo nei mos montati.

Stai attento, se sali tanto in frequenza rischi che un mos si accenda prima che l'altro si sia spento e metti in corto l'alimentazione...

Janos: Stai attento, se sali tanto in frequenza rischi che un mos si accenda prima che l'altro si sia spento e metti in corto l'alimentazione...

Corretto, però per ovviare esiste una cosa che si chiama deadtime, ovvero c'è un certo ritardo, voluto, tra lo spegnimento di un gate e l'accensione dell'altro, sul RoboPonte tale ritardo è impostato a 180ns in hardware tramite il driver utilizzato (HIP4081), i micro con generatore pwm specifico per il controllo motori, p.e. pic 18F2431, consentono di gestire il deadtime in hardware e impostare a piacere questo tempo. Da notare che il deadtime serve solo se controlli il ponte in modalità LAP, dove vengono commutati in continuazione tutti e due i semirami del ponte alternando i mos, mentre in modalità S/M, dove si tiene sempre in conduzione il mos low side e si commuta col PWM quello high side, il problema non esiste salvo quando si deve effettuare l'inversione del senso di rotazione, in questo caso la cosa viene gestita dal controller portando prima il PWM a 0 e poi attendendo 200-250 ns prima di commutare la coppia di mos da utilizzare.

ma se aumenti la frequenza non intervengono le perdite dovute all'induttanza del motore?

il circuito a 36v è uguale a quello a 60? non posso sostituire i mos?

garinus: ma se aumenti la frequenza non intervengono le perdite dovute all'induttanza del motore?

L'induttanza del motore è quello che ti permette di usare il PWM per variare la velocità, è per il suo effetto che il motore vede una tensione equivalente, quasi costante, invece di una tensione che va e viene, o peggio una che si inverte in continuazione nel caso del controllo LAP. Proprio perché si deve sfruttare l'induttanza è necessario usare frequenze relativamente elevate altrimenti si che hai perdite, va da se che oltre un certo limite (parliamo di molte decine di kHz) l'impedenza degli avvolgimenti assume valori che sommati a quello puramente resistivo delle spire di rame riducono non il rendimento, ma le prestazioni del motore, più resistenza in serie vuol dire meno corrente (= coppia) che può scorrere nel motore a parità di tensione, poi tocca fare i conti pure con la f.c.e.m. però questo è un discorso diverso.

il circuito a 36v è uguale a quello a 60? non posso sostituire i mos?

Lo schema è identico, però cambiano anche alcune cose nei valori dei componenti a seconda del tipo di mos montato.