Hackvision/FTDI Issues

I'm trying to upload programs to a hackvision which uses an Atmel 328P and using a FTDI to USB breakout board to conncect it to my computer (64 bit Windows 8,latest IDE and last stable FTDI driver distribution) and I'm getting an error which says:

avrdude: stk500_getsync(): not in sync: resp=0x00

I have the hackvision set as an Uno on COM6. I've heard there can be a lot of causes for this error but would it be easier to just get a 5V FTDI to USB cable rather than deal with driver issues on the breakout board?

These are what I have:


There is an issue with FTDI driver, later versions soft-brick a fake FTDI chip by overwriting Device ID to 0000. The original is 6001, check the Device ID in device manager in the properties of the COM port that FTDI uses. (don't know the win8 device manager's analog)

There is a FTDI utility called FT_prog you can use to bring Device ID to the original value. You also need to uninstall the driver with CDM uninstaller. Then install drivers from https://dl.dropboxusercontent.com/u/41437886/FTDI%20USB%20Drivers.zip

I don't remember the right sequence of driver install/uninstall but you should have all the tools now.
Try a loopback test to see if the FTDI adapter works.

I did the entire workaround with the downgraded FTDI drivers, used FTProg to tweak the PID back to 6001, installed the FTDI bus and port drivers, and tried the loopback test, which was successful, but there is still no response from the hackvision.

Double check the PID and the connection between RX and TX pins on the adapter again.
I managed to fix my FTDI but this is all I can help right now 'cause I'm also getting a no response error, with different boards although. Maybe someone else can help.