Have I an Arduino dammaged ?

Excuse me first for my bad english langage.
I don't find in the past posts the solution to my problem.

I am implementing a system with a GSM shield (SIM900 based) and an arduino Uno. I want to send messages SMS for instance, automatically of course. I'm working with Windows 8.

In order to run the system without computer, it has its own battery. It seemed to work nearley well. Even when I connect it to the PC via USB (in order to have information on the process with the monitor) it seems to have no problem. I had read that it is allowed to have the two sources of power at the same time (the main source is 9 volt (regulated) on the Jack).

But when I have tryd to uploading a modified sketch, it was impossible to upload it. Since that operation, nothing was more possible to do with this Arduino. The error message is about: impossible to open the port .

I have checked all I could on my PC, delete and download the entire Arduino IDE System (with good driver then), tried all USB connecters I have on my PC, tried to upload the bootloader, in the case of it were deleted, but not any communication is possible, even the very simple sketch for blink a led....
Having a second Arduino Uno, I tried it, and it works. So actually I can work with this one. But I would not to dammage this one also....I'am not so tranquillized >:(

Prudently, I shall disconnect the power battery when I'll have to upload a sketch. But I whish to understand wat happend.. :o .

Thank You for advance
regards : gege62 :slight_smile:

Do you have the correct COM port selected? On my computer different Arduino board were assigned different COM port so I have to change in the Tools menu when I change the board.

Yes I have.
moreover, often enough I have to go trough the "configuration panel" to "force" the port to open, (disconnect , then reconnect fonctions). But generally, when the port is on, it is the good one (effectively, each Arduino has its own port, that is mysterius for me, because the arduino are all the same..?)

During uploading attempt, all seems good from beginning to almost the end. Only at the end, the uploading does'never terminate, nothing more happend. Just every 10 seconds, a small blink appears on the "Rx" light. Even the error message does not come at this time, it cames only when I make another attempt.

Seeing this after my post, I have made the test according to Coding Badlly: Loop-back Test Instructions, posted 28/9/2011.
The test works good. Wery strange....

Another thing, may be not reliable: the reset button does not make any reset. But I do'nt utilize it very often, so I don't know if it is new, and if it is important.

Thank You anyway for your intervention.


GSM shield is probably using Arduino Rx,Tx pins (0,1) which are used also for programming via USB. It should be the problem. Try to disconnect the shield and uploading should work back again if so.


No, pins 0.1 are allways used for arduino to/from PC only, communication with the shield is made trough pins 8,9, by creating there a virtual port (this is made with the library Software serial).

When I was looking to solve my problem, of course my arduino was nude and with USB only connected.

But thank You for your answer.

Another thing:

Yesterday evening being replacing the Arduino on the device, and I have discovered a mistake in the connections:
instead to give 5 V on the Input A0, it was 13 Volt....so I suppose that Arduino did not appreeciate this.

May-be it is the cause of the problem, but pins 0 and 1 was not directly in concern with that. So I don't know..

Thank You.

A chance for me to have seen this mistake before filling the second one....I shall a good customer for arduino makers...!!!

At the moment, I have to consider my arduino n°1 as killed, I wonder if may be the atmega 328 is good and the micro 8U2 witch is used for communication is bad, but have no possibility to verify this.