Have Yun! need to uploads sensor data to xively but no joy.?.

Hello.

Hope someone can help. I had an uno with wifi shield attached and sending data to xively was no problem but the shield was terrible connecting once out of ten times and then died altogether.

Got rid of the shield and got a yun for the onboards wifi but cant get much to work?.

In can see wireless networks but cannot connect to them.

I have tried the bridge examples e.g. To connect to wpa over bridge but can never connect

It tries and then says something like

"are you using the bridge"

All i want to do is uploads a thermistor analogue output to xively? Can it reall be that difficult?

Im on win 7 any help would be really appreciated

Thankyou

Let's start solving the first problem, or we may get stuck with false positives.

First thing you need to do is to make sure the yun is connected to your wifi. Do you have a wifi connection available? Have you configured the yun to connect to it?

If you did and it failed, wait for the yun to get back in access point mode, then go again to its webpanel: in the homepage there will be a textarea with the error log. Can you attach that log to this thread?

Thankyou for the swift reply i will look into that now and get back to you

Hi. I cant even get the Yun page up now ... http://arduino.local or 192.168.240.1????

So i dont know whats happening??? I can see and am connected to my home network and can see the arduino one....Arduino Yun 90.......etc.

When i connect to the arduino connection i cant get to arduino local or my home network.??

Yesterday they seemed to be connected together with the i.p address as 192.168.240.5??

Any ideas.??

Going mad here....Knew i should have stuck to big yacht engines like a caveman lol

Please start heading your browser to this link http://arduino.cc/en/Guide/ArduinoYun#toc13 and keep it open Power up the yun and connect your computer to the wifi it creates: Arduino Yun-ABC123... Carefully read the "Configuring the onboard WiFi" paragraph on your browser and follow all its instructions. As soon as you get stuck, get back here and describe the steps you've taken. If you think it may help us helping you, provide a screenshot of the problem

it just wont open that page in the browser??? is my Yun dead…?? i have tried resetting it a few times??

Picture attached!

regards

Ok, two tests then - open the latest IDE (1.5.4r2 for windows) and check to see if the yun is showing up in the port menu as something like 192.168.0.5 (Arduino Yun) - instead of http://arduino.local, try http://192.168.240.1

Yes the Arduino is showing up there as you can see in the image i have attached and i can blink the LED through this but this seems all i can manage??? if i try to connect to a network i.e. the wi-fi status example it just…fails to connect and then says are you using the bridge?? am i being stupid? am i missing something??

Thank-you for your help!!!

regards

it shows up when connected to the Yun network in the IDE but not when connected to my wifi router SKY69374

All examples but those whose name starts with Console uses plain old serial connection: select the COM port and rerun the wifistatus

megayachtengineer: it shows up when connected to the Yun network in the IDE but not when connected to my wifi router SKY69374

When your computer or your yun is connected to the router?

Anyway, go ahead with configuring the yun and then run the wifi status example and then report back

i disconnected from the arduino and used the com 3 run the wifistatus sketch and this is what i got?

Which board have you selected in the board menu?

The Yun board.

Uhm I'm not sure of that COM3 port then. If you unplug the yun, it should disappear from the IDE. Can you try? As a double check, when you plug it in again, does it reappear?

is it broken? i dont get why its so difficult and wont load up the configuration page? I have the i.p of the yun in the tools/ port menu! I try to send a sketch as copied from the example xively string library in the bridge example sketch in the IDE with my api and feed id changed of course and nothing??

???

This is for my final year uni project and wanted to step outside the box as a mechanical engineer but maybe a bridge to far or im jinxed ??

regards

hi

Yes the com 3 stays there.

I think i will shut down and restard my laptop and then re-install the IDE and go from there?

ill get back to you on my findings as i take it that port should not be there?? or maybe it should?

I think you're missing the yun drivers. Have you installed the IDE with the installer? It makes life easier As a double check, your windows device manager should have an uknown arduino yun listed (when the yun is plugged in)

i have just reinstalled the IDE and it seemed to go alot quicker and didnt hang up on the 32bit driver section so ill try again now and get back to you

regards

ok mamaged to reinstall the IDE and got the blue yun url working! reconfigured the yun and now the arduino yun 283… is gone from the wifi available connections and in the IDE i now have in tools the arduino as 192.168.0.5 so i take it that is ok?? the com3 is still there but as the SKY69374 is what im connected to on my laptop yet i can still see the arduino yun in tools that this is correctly set up???

Still cant get anything from wifi status but unable to connect??? strange?!?!

i can send the blink program through the internet to the yun to change the frequency of the blink so surely im connected over wifi!!!! so why cant i send info to Xively from analogue sensor which is the initial problem?

thanks