Having a problem uploading to a Arduino (clone) Mega 2560 board.

Hello, I'm new to this so please bear with me.

I'm having a problem uploading to the Arduino Mega2560 (clone) board that I purchased. This is the link http://www.ebay.com/itm/231183966414?_trksid=p2060778.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

OS is Windows 7 - 64 bits. The installed driver seems to be ok; it shows up as "Arduino Mega 2569 (COM8)" in the device manager. In Arduino 1.6.0 software tools/board it shows up as "Arduino Mega or Mega 2560" on COM8. So it appears to be installed correctly. When power up (USB) both the Green power and "L" leds are on. If I push the reset button the "L" led flashes.

When I try and upload a sketch, it fails with a time out error. "avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_getsync(): timeout communicating with programmer" From the description of the board, it appears to have a boot loader installed.

But I was wondering what would happen if I clicked on "Burn Boot loader" in Arduino 1.6.0. Would it try to install the boot loader for the mega 2560?

It uses the ATMEGA2560 16AU 1420 and MEGA 16U2 1426 chips.

  1. Iduino Mega 2560 Board Iduino Mega is an ATmega2560 as core microcontroller development board itself has 54 groups digital I / O input / output terminal (14 groups do PWM outputs), 16 sets of simulation than the input side, group 4 UARTs (hardware serial ports), using the 16 MHz crystal oscillator. With the boot loader, download the program directly via USB without having to go through other external writer. Supply part of the optional USB power, or as an external power using the AC-to-DC adapter and battery. Arduino development IDE interface is based on open-source principles, allows you to free download for use in project work, school teaching, motor control, interactive works.

Thank you

Is that an "Arduino Mega 2560" compatible or a "Arduino Mega" compatible ? Can you read the chip ? Did you select the right board ?

To burn a bootloader, you need a programmer. An Arduino Uno can be used as a programmer, called ArduinoISP.

It looks like it features the standard USB to serial chip. Have you tried another USB cable or port (or indeed both)?

Item #2 above was taken from the sales add. It is an Arduino Mega 2560 clone. In Arduino (Ver. 1.6.0) when you select the board it says "Arduino Mega or Mega 2560".

Yes I have tried 2 cables and both com8 & 9.

Atmel 16U2 http://www.atmel.com/devices/ATMEGA16U2.aspx?tab=parameters

Thank you

Read this getting started guide.

In particular the bit about installing the drivers.

The “iduino Mega” and “iduino Mega R3” are all ATmega2560. That’s good.
If the drivers are okay, then the bootloader might be wrong, as you were expecting all along.

Did you read about using an Arduino Uno as ISP ?
I use a USBasp programmer version 2, with a 10-pin to 6-pin adapter for the ICSP header on the Arduino board.
And I always burn a new bootloader to a clone/fake/compatible Arduino board, since I don’t trust those.


Thanks for the help and I was reading about using the Arduino Uno as ISP but decided I needed a break for an early lunch. While watching part of a movie an idea occurred to me. So for now I'm done with the programmer but will pick it up again later. OK.... So

Well as it turns out I had Com8 defined twice. Once as it's own com port and once linked to com port 18. I use a program to define sets of com ports for other software that I use. I have a total of 26 com ports defined and from com port 7-26 they are defined in pairs. Like 7-17, 8-18, 9-19 etc... Once I deleted 8-18 the MEGA 2560 uploaded fine. :confused:

Thanks for the help.

I'm glad you found what caused the trouble :) I would have never thought that someone would have 26 COM ports :o

Yep 26 is a lot. I use a radio which is software defined. Just as we are controlling our printers you can also define radios. With the supporting software, controlling an antenna, power meters and other equipment, well it takes a lot of com ports. Out of 26 only 6 are hardware and the rest are virtual. :roll_eyes:


Hi all, i've been looking for this problem for 1 week. I have a Uno and mega 2560 both clones with ch340g serial chip. Same problem, arduino mega 2560 stopped responding to upload any sketch. i thout it was the bootloader, so i burned the bootloader using Uno as ISP. Without luck. So what i dit to resolve th problem.... i sacrified the Uno :)) i took the ch340g chip from uno and soldered to th mega and bam!! the problem solved, probably something wet wrong on my ramps board, have to check. So if any have this problem, just check the serial chip.

my new arduino mega 2560 is not recognised by windows 8

Windows8 was a dog. Upgrade to 10. Also, check that you have a driver for the USB interface chip on the board. Is the chip next to the USB connecter Atmega16U2, or something else?