Having some issues with DT-06 DOIT TTL-Wifi module

Good day,

So I’m new to Arduino but I’ve been working with automation for a while now…

I used to buy a bunch of DT-06 DOIT TTL-Wifi module from amazon for a reasonable price and they’ve been working well over the time. But I had some issues with one (basically I was getting some garbage on the ttl port so I tried to reflash it. Since then, device is dead… No led no nothing…
The only thing I can do is to put it in flashmode again and push a firmware to it… But as you guess, I can’t find any appropriate firmware for it and the device is probably a clone and not binaries I’ve found on DOIT forums are working… That why I’m sollicitating your help :slight_smile:

this is what esptool tells me about it:

Detecting chip type… ESP8266
Chip is ESP8285
Features: WiFi, Embedded Flash
Crystal is 26MHz
MAC: 84:0d:8e:zz:zz:zz
Uploading stub…
Running stub…
Stub running…
Manufacturer: 51
Device: 4014
Detected flash size: 1MB
Hard resetting via RTS pin…

Could anyone help me recover this little guy ?
I even tried to dump the firmware from another one to this one without success :frowning:

https://store.arduino.cc/arduino-wifi-101-shield