Having trouble with Windows 8? Quick Fix Guide

Having trouble with Arduino IDE and Windows 8? Well the first problem is that you have Windows 8. I had a ton of trouble getting my Arduino to program for the first time, so to save yourself a headache, here are a few fixes.

  1. [u]can't install a signed driver[/u] Windows 8 won't by default let you install an unsigned driver, but you can get around that. Here's a link: http://www.youtube.com/watch?v=CdE72XUYC7k

  2. [u]Can't launch arduino.exe[/u] In certain circumstances browers won't let you download executable files. In the root folder of the zip you downloaded, there should be a file called "arduino.exe". If it is missing, try another browser or another zip utility (I like 7zip).

  3. [u]driver folder is empty[/u] If there are no driver files in the driver folder, but the folder structure is preserved, do the same as above.

  4. [u]my board doesn't show up in the menu tools -> board[/u] If you have a Due board, it is not supported by 1.0. You need to download the 1.5.1r2. http://arduino.cc/en/Main/SoftwareDue

  5. [u]can't upload code to arduino[/u] Are you plugged into the right USB plug jack (Due only). Are you connecting over the right Com port? When attempting to program via the IDE, you may get an error "No device found on COM1". However, your device is not necessarily plugged into COM1, and aruino won't easily let you change the COM port. Find your device in Device Manager -> Ports -> My Arduino Board -> Right Click -> Properties -> Port Settings -> Advanced -> Look which COM port number you have. By default arduino programs to COM1. I don't recomment changing the port number here. Instead, change which port Arduino tries to program to. Go to C:\User\MyAccountName\AppData\Roaming\Arduino. Open preferences.txt and search for "COM". Change the COM number to the right value and relaunch Arduino.