HC-05 at commands don't respond in at mode

So i have an arduino mega 2560 and a bluetooth module HC-05 , and i followed the following guide , and i was able to put my bluetooth module into at mode (the led blinks slower than usually , an interval of around 2 seconds ) and when i opened the serial monitor on my pc , the arduino printed to insert an at command , but for some reason i wasn't able to use command , even at to check the connection didn't work . The weird thing is that a couple of weeks ago i used the same bluetooth module with the same guide and software and the same arduino and it worked fine , i was able to change the name of the bluetooth module and control it without any problems , then i came back to that project and wanted to make sure everything worked fine , and suddenly it doesn't D:
Any one has a clue why suddenly i can't use at commands ?

Since you gave done it before, I assume the code is kosher. The slower flash rate confirms you are indeed in AT mode, but that is not dependent on the comms wiring, only power and KEY. Therefore. check Rx/Tx.