HC-05 module commands execute but module does not acknowlegde


I'm using a HC-05 bluetooth module with an Arduino Mega. The HC-05 is connected to the Serial1 port.

When sending an AT command to the HC-05 it is executed, however the HC-05 does not acknowlegde with 'OK' or 'FAIL'. I have connected a Digital Storage Oscilloscope(DSO) to the RX and TX lines and can see the command being sent from the Arduino. No acknowlegde from the HC-05 is measured on the DSO though.

When sending, e.g., AT+NAME=BTTEST, I can see the name has changed on my PC (Mac) in the pairing window. However, the command is not acknowlegded.

I tried to pull-up the lines, no change.

Pairing, also working fine with password 1234.

So, my conclusion is, the HC-05 handles my commands and is working fine. Has anyone seen the behaviour on a HC-05?

Although there weren't any replies sofar, it seemed bset to update this thread with the solution anyway. Perhaps it can help others in the future.

I bought two new modules which responded on the AT commands. It was a hardware failure after all.

Still, some strange behaviour still exists. When sending e.g. AT+NAME? it does not respond with the name immediately. After sending AT it responds with its name. Something to work on..

It may indeed be hardware failure, but one reason for the absence of replies is that your post made no sense, and the oscilloscope isn’t really telling you anything about the HC-05 per se anyway. The second post rather suggests that the problem isn’t actually solved, and the real question is - how come, after all these years of HC-05s being around, you are having a problem that nobody else has?