HC-SR04 + Ableton --> Series monitor shows input, Ableton not receiving signal?

Hi Everyone,

I've googled this pretty extensively, searched the forums, and found tons of useful information, but nothing yet that addresses the challenge I'm facing. Reaching out here to get some advice/guidance.

I've put together a sketch based on a couple of different tutorials to use the HC-SR04 sensor with Arduino Uno (with StandardFirmata installed - I tried combinations of installing Firmata first and then running the sensor sketch, and also doing the sensor sketch first and then installing StandardFirmata). When I open Series Monitor, I get what appears to be an accurate reading of the proximity of an object to the HC-SR04 sensor. It seems like everything is fine with the sensor and Arduino.

I have the Arduino plug in opened from the Connection Kit in Ableton, but here's where the challenge seems to be. I've attached a screen shot of my Ableton window. I've also attached a screenshot of a youtube video where you can see the difference between that person's Arduino plug in and mine - the difference I notice is that I cannot get any type of indicator to come up next to D6/D7 like the one that the person in the YouTube video has. This leads me to think that maybe Ableton is not receiving a signal from Arduino? This is bizarre because as I mentioned I installed Firmata and SeriesMonitor indicates that there's a signal flow coming in from the sensor to Arduino.

If anyone can help advise/guide me I would be very grateful!

#define echoPin 7
#define trigPin 8

long duration;
long distance;

void setup() {
  // put your setup code here, to run once:

Serial.begin(9600);
pinMode(echoPin, INPUT);
pinMode(trigPin, OUTPUT);
}

void loop() {
  // put your main code here, to run repeatedly:
digitalWrite(trigPin, LOW);
delayMicroseconds(2);

digitalWrite(trigPin, HIGH);
delayMicroseconds(10);

digitalWrite(trigPin, LOW);

duration = pulseIn(echoPin, HIGH);

// this gives distance in cm
distance = duration/58.2;

Serial.println(distance);
//milliseconds
delay(50);
}