HDG104/HDG204 - Arduino WifiShield Failures

I run the Arduino WifiShield on an Arduino UNO R3, using the 1.5.2 IDE. I had three of these devices in working state, communicating with a remote server, serving up monitoring data.

I had erratic wifi connections with one of the Wifishields, and tried to update the firmware to the latest in the github repository to see if that would make any difference. Used the Windows Atmel Flip programmer and tried to follow the website information. However, the device on these Wifishields is not an AT32UC3A1256 but is an AT32UC3A1512. So the batchisp.exe command line was changed to reflect that. The resultant issue is that the Wifishield is no longer erratic but sits in ERROR (red LED on constant).

I ordered another WifiShield to replace that one and noted that the new WifiShield has an HDG204 on the device. This WifiShield refused to even go beyond a constant ERROR (red LED on) direct from the box. The suggestion from the supplier was to try and upgrade the firmware - when that failed to move anything along, I am now returning that WifiShield and purchasing another.

I understand that the HDG104 and the HDG204 are fully binary compatible - thus the github repository does not need to be updated but perhaps the website could reflect any changes made to the WifiShield componentry.

My real question is this - does anyone from the WifiShield development have a Hardware Failure Rate for this Arduino WifiShield? As I am using this to prototype a system I will not be leaving too many in the field but two failures out of three is a very high failure rate, at the cost of the hardware.

Is there any suggestion as to what to do with a WifiShield that is in ERROR, other than a lightweight paperweight?

Tim Bennett

A quick scanning of forum showed

  1. User community sticks with ethernet LAN based shield
  2. Seven out of 10 user have problem running Wifi shield
  3. Eight out of 10 run into issue upgrading the firmware
  4. Nine out of 10 need to use Arduno 1.0.2 (not the latest IDE) to get WiFi working
  5. We still can't get static IP address to work! even after firmware update.

We too have a "AT32UC3A1512" but issued command successfully. batchisp.exe -device AT32UC3A1256 -hardware usb -operation erase f memory flash blankcheck loadbuffer c:/wifi_dnld.elf program verify start reset 0


Hope this helps, Team BTF

Thanks for the feedback

After many software upgrades, the wifishields have returned to working.

The re-use of the chip name AT32UC3A1256 for an AT32UC3A1512 works due to the code size, the use of the proper chip name does a larger erase as the internal flash is double the size (512 Kbytes versus 256 Kbytes)