Help Boot loading 328P AU custom board….

Would be grateful if someone could sanity check this schematic for me… All seemed to be great on the breadboard but after i assembled the board, i can't communicate with the m/c. Cant read device ID or anything. the ICSP programmer is not the issue here….

R9 is 60.4?? That's pretty low and may be loading the programmer too much. I might try removing it (or the LED, whichever is easier) from the circuit to see if that helps.

R9 is actually 287 ohm now… But other than that,, it looks ok?

I may have killed something when i assembled the PCB. IS there anything else i can try? Thinking i might boot load the processor before soldering in on. Any ideas about this?

thanks for looking, i really appreciate it

Yeah seems OK, nothing is jumping out. There are TQFP test sockets available, not terribly inexpensive but probably the best thing for the job, e.g. http://www.adafruit.com/products/1240

(I think that one would fit the 328-AU but I haven’t read the doc so be sure before you buy!)

Cheers Jack!

Guuna heed the advice, take a step back and program the chip with a test socket. Ill then add components to the breadboard and check functionality as i go before i try soldering up another pcb.

Good luck, be sure to give us an update. I might try soldering up another board just with the MCU, crystal and other support circuitry, and see if I could upload the blink sketch.

Ok, so i went back to basics and got hold of a programming socket and some through hole components and just built the bare minimum… but still the same issue!!

I tried 2 new 328Ps out the bag from DigiKey, so i know they are good. The AVRISPmkII Clone works when connected to my mega2560 and reads thats fine… i just keep getting the error message, even when trying to read the device ID. I can't even get a boot loader on there!

There must be something simple (other than me!) thats going on :/

Are the results the same if LED3 or R9 are removed from the circuit? I've had problems with ICSP if there's too much load on one of the SPI pins, 150? is kind of borderline in my experience, might work or might not...

Although you've already got the programming socket, for anyone else dealing with the QFPs, if you're only dealing with a couple of them you can use a qfp breakout board and just hold the chip to the board with something like a large paper clip. I've even seen postings of people saying just pressing the chip to the contacts with their finger worked.

On your picture I see nothing plugged into pin 29 of the 328 where it is plugged into the protoboard. You schematic is calling for the pullup resistor for the -RESET line.

When using the MKii, are you powering the device elsewhere? MKii does not provide power, it only monitors what is there.

JoeO: On your picture I see nothing plugged into pin 29 of the 328 where it is plugged into the protoboard. You schematic is calling for the pullup resistor for the -RESET line.

@Crossroads…. its actually a ZeptoprogII … & powering the breadboard from a mega2560 next to it

Yeah its a crazy Chinese Socket!! Pin 1 from the m/c actually pops out of pin 5 on the dip board :/ ...far side of socket dip connections runs 29-12 and the nearside is 13 through 28 of the actual chip!!

Jack, you did it again!! swapped out the 150 for a 330 and it could then communicate in AVR studio :)

Now i have the following Bootloader on there, running at 8MHz and 3.3v:

ATmegaBOOT_168_atmega328_pro_8MHz.hex Low Fuse 0xFF High Fuse 0xDA Extend Fuse 0x05

Now i have a problem with uploading the sketch, using an FTDI Friend. I have reloaded FTDI drivers, reinstalled the IDE, triple checked all the wiring and settings within the IDE. I have tried about every possible combination of manual resetting, DTR and RST and keep getting the following error:

"stk_500getsync(): not in sync: resp=0x00"

Its so close now, thanks for all the help so far guys… just this last step to go, Perhaps its the jumpers on the back of the friend….

I have also taken the second m/c and loaded the following:

optiboot_atmega328_pro_8MHz.hex Low Fuse 0xFF High Fuse 0xDC Extend Fuse 0x05

but again the same error occurs. It seems to reset the m/c ok and the tx LED on the Friend blinks 3 times, it just never goes further than that. I need this to work for changing sketch in the future, i can't just use SPI to upload the sketch as the work around.

thanks in advance!!!

LightningBug: I have also taken the second m/c and loaded the following:

optiboot_atmega328_pro_8MHz.hex Low Fuse 0xFF High Fuse 0xDC Extend Fuse 0x05

If that is this bootloader, try L/H/E = 0xFF/0xDE/0x05

Hmm, tried those fuse settings but still no good.. also tried a couple of different upload protocols and nothing again…. Im beginning to suspect my FTDI Friend has a problem. I never tested before before but it fails uploading to my mega2560. Ill try a different adapter and report back thanks!

Ok, so i tried a new FTDI adapter and i still get the same error! Everything works fine with a ProMini 3.3 8MHz clone.

Is there any chance its one of my passives that causing the issue?

0.1uF caps Kemet C322C104M5R5TA 50V 20%

22pF caps kemet C317C220J2G5TA 200V 5%

Xtal CTS Freq Controls ATS08A-E 8MHz 20pF Load

I am without my windows box, so can't download the Bootloader from the working ProMini Clone, or check its fuse settings

any more ideas?

LightningBug: any more ideas?

Hmmm, running out. The caps seem reasonable. Have you burned the bootloader more than once? If not, try it please, that should verify that there is a good clock.

I have successfully burned both boot loaders several times to a single m/c and repeated the whole process with different chips from different sources. What i will do is wait till i get my PC back and proceed as mentioned in my previous post. Ill read the known good settings from the clone mini i have and write them to my setup, if it doesn't work then… well I'm not sure what else to try. It might be possible to eliminate the external clock and use the internal one, this will remove 3 more components and maybe give more of a handle on whats going on… thanks again for all the advice, ill keep you posted!

At long Last... Success!!!

Been away on vacation and had to get a new HDD fitted to the computer, sorry for the long delay.

Im not sure what fixed the issue but i bought a new FTDI adapter (that turned out not to be the problem) and a ProMini 3.3v clone. I then downloaded the flash and EEProm from it and read out the fuse settings. I then transferred all of these over to the Breadboarded ProMini i built and it all started to work fine! I also changed the ARVISP to Default of 125k Baud.

Thanks to everyone for all your Help :D

So settings that worked for me...

Extended Fuse: 0xFD High Fuse: 0xDA Low Fuse: 0xFF

and I'm not sure if these are needed or how they compare to others there but i included the EEProm Hex thats working and i used the Optiboot loader as mentioned above.

EEprom Hex

:10000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00 :10001000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0 :10002000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0 :10003000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFD0 :10004000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0 :10005000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFB0 :10006000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFA0 :10007000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF90 :10008000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80 :10009000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF70 :1000A000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF60 :1000B000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF50 :1000C000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF40 :1000D000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF30 :1000E000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF20 :1000F000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF10 :10010000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF :10011000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFEF :10012000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFDF :10013000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFCF :10014000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFBF :10015000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFAF :10016000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF9F :10017000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8F :10018000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF7F :10019000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF6F :1001A000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF5F :1001B000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF4F :1001C000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF3F :1001D000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF2F :1001E000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF1F :1001F000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0F :10020000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE :10021000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFEE :10022000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFDE :10023000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFCE :10024000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFBE :10025000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFAE :10026000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF9E :10027000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8E :10028000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF7E :10029000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF6E :1002A000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF5E :1002B000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF4E :1002C000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF3E :1002D000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF2E :1002E000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF1E :1002F000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0E :10030000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFD :10031000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFED :10032000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFDD :10033000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFCD :10034000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFBD :10035000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFAD :10036000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF9D :10037000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8D :10038000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF7D :10039000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF6D :1003A000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF5D :1003B000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF4D :1003C000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF3D :1003D000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF2D :1003E000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF1D :1003F000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0D :00000001FF

LightningBug:
I also changed the ARVISP to Default of 125k Baud.

I was going to ask about that at one point, but it must have escaped me. What was it set to before?

to be honest Jack, i don't think that change in baud made any difference. All that was, was a change in the AVRISPmkII clone that i was using for uploading the boot loader and setting fuses. That was all working fine after your initial help. It was the sketch uploads from Arduino IDE using an FTDI adapter that was causing all the grief. It must have been a combination of the fuse settings and the boot loader i was using. Just reading out the know good ProMini and copying over everything goto t all working.

Others with more experience and better analytical skills could probably work out the root cause.

thanks again