Help! Issues Uploading to Arduino Micro

Hello,

I'm having problems uploading to my Arduino Micro, when previously I didn't have any problems. Here's the detail:

I'm sort of getting a cycle of upload successes and failures. I am able to upload 'Blink' without a problem, meaning it shows 'Done Uploading' on the screen. But if I upload it again, it gets stuck at 'Uploading' and it will also show Couldn't find 'Leonardo on selected port', and it also sometimes shows 'Problem uploading to board.' The LEDs on the board are sporadic, if the 'Blink' program doesn't work then the TX LED sometimes blinks, but most of the time none of the LEDs, except the blue power LED, are lit.

The code I'm trying to upload is basic: it only uses 2 digital I/O, and no serial monitor.

My Micro and Uno worked fine for a long time, but this problem seemed to start only when I used the serial monitor in a sketch with my Micro. My Uno has been having similar problems, but they're not as severe. My Micro is relatively new; it only got used for a few projects and I'm 99.99% sure that there's nothing physically wrong with the board.

Things I've already tried:

  1. Uploading a variety of sketches
  2. Holding reset while uploading
  3. Reinstalling drivers for bootloader and board
  4. Changing the serial port

System: Windows 7, Arduino IDE 1.0.6

I'm having similar results using the Arduino IDE in Raspbian on the Raspberry Pi as well, when it used to work fine. Both uploading in W7 and RPi stopped working at the same time, leading me to assume that it's how the board is connected to the computer.

I've googled extensively and searched this forum and could not find a solution.

Thank you for any suggestions you can provide! :slight_smile:

Having the same problems...