Help me think of good names for this

I'm working on my arm controller and the same code handles a gimbal. The servos have two modes with a joystick. One where the joystick just makes the servo move in the direction it's being pushed and the further you push it the faster it goes in that direction. When you release the joystick the servo stays where it is.

The other mode is where I just write the reading from the stick directly to the servo. In this mode the servo always follows the stick and when you release the stick and it goes back to the middle the servo goes back to the middle too.

I need some good names for these two modes. This is stuff that's going to be around for a while in my code. I'm thinking of followTheStick for the second one, but what about the first.

Got any good ideas? I don't want to run afoul of PaulS for having stupid names.

autoReturn and manualReturn

~Tada

"sticky" and "fluid" ?

...R

Rate Mode and Position Mode?

" I don't want to run afoul of PaulS for having stupid names."

probably too late for that!

Robin2:
“sticky” and “fluid” ?

…R

No. Not “sticky” and “fluid”. This is a family forum.

So no friction and grind then?

ChrisTenone:
No. Not "sticky" and "fluid". This is a family forum.

Then I suppose that "come" and "go" are out of the question.

We have restaurant called In n Out so it must be safe on forum. Use In and Out for the 2 names.

Uhh…

Family friendly...
Shuttle (go. stop. go some more.)
Recoil (go. draw back.)

Hi,
Industry calls the first mode "JOG", the second mode "JOYSTICK"

Tom... :slight_smile: