Help needed to uploading to Zero board

Hi, I am david , and I am new to Arduino. I got a Arduino Zero (M0 Pro R3). Tried to load a test program to the board and failed. I followed the procedure about "Uploading trouble shooting" very carefully, and the problem did not go away. Your help is much appreciated. Thanks.

Here are the message returned by IDE:

Arduino: 1.6.5 (Windows 7), Board: "Arduino Zero (Programming Port)"

Sketch uses 11,060 bytes (4%) of program storage space. Maximum is 262,144 bytes.

Open On-Chip Debugger 0.9.0-gd4b7679 (2015-06-10-22:24)
Licensed under GNU GPL v2
For bug reports, read
debug_level: 0
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x81000000 pc: 0x000028f4 msp: 0x20002c00
** Programming Started **
auto erase enabled
Error: SAMD: NVM lock error
Error: Failed to erase row containing 00002000
Error: error writing to flash at address 0x00000000 at offset 0x00002000
Runtime Error: embedded:startup.tcl:454: ** Programming Failed **
in procedure 'program'
in procedure 'program_error' called at file "embedded:startup.tcl", line 510
at file "embedded:startup.tcl", line 454
the selected serial port at file "embedded:startup.tcl", line 454
does not exist or your board is not connected

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

Hi, I am having the same problem. Any luck about this one ? Is this already solved ?


It's a bit like "mentioning the rope in the hanged house" ::slight_smile: (old spanish proverb): have you tried the IDE?.