Help please? Project 7 trouble uploading (or running)

I finished project 7 and i do not know how to run it.
this is the code
Arduino: 1.6.8 (Mac OS X), Board: "Arduino/Genuino Uno"

Build options changed, rebuilding all

Sketch uses 4,140 bytes (12%) of program storage space. Maximum is 32,256 bytes.
Global variables use 231 bytes (11%) of dynamic memory, leaving 1,817 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "COM1": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

when we try to upload, this is the error message

Arduino: 1.6.8 (Mac OS X), Board: "Arduino/Genuino Uno"

Build options changed, rebuilding all

Sketch uses 4,140 bytes (12%) of program storage space. Maximum is 32,256 bytes.
Global variables use 231 bytes (11%) of dynamic memory, leaving 1,817 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "COM1": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Project 7 what?

Is your board actually at COM1? Look under tools/port and lets see what com ports are available.