Hi All, How are you doing. I am trying to connect the arduino with my windows vista. And these are the errors I am getting can anybody help me out. Also Can you please let me know if I can get zero or one from arduino touch shield.

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Sorry I forgot include that I have Arduino Duemilanove which I am getting these errors for.

Again I thank you in advance.

Is anything connected to the RESET pin on the Arduino? I got this error when I had a LCD connected to the reset pin. If so, try disconnecting anything from the reset pin and see if it works :)

No, Nothing is connected I just got it out of the box connected it to the computer to see if it works and that this is the error i am getting.

First you need to check the chip on your board and see if it's an ATMEGA328 or ATMEGA168, then goto Tools, Board and choose the correct board, it'll be one of the top two. Also, if you have the right board selected, check the Serial Port, try all of them and remember whichever one it works for.:)

Then, next time you post something like this, try put it in the right area!:D I don't think this qualifies as a workshop. :)

Welcome to Arduino! You should take a look at this manual as well, might as well save it to your hard drive it's very good!

I have ran through All The basic trouble shooting techniques and have switched computers and have come to the realization that I think I need the boatloader. How can I install or burn that on to my Atmega328.


I am going to move this post to general Hardware questions, it doesn't proceed to have this on the workshops forum.


sounds really strange that your board is not having the bootloader. I would first try to install the drivers to the board from FTDI using the executable from their website. Sometimes, Windows Vista under some computers, brings problems due to specific OEM drivers put in your machine by the computer manufacturer.

Try to get the file at:

which is an installer compatible for all sorts of Windows machines, it will whipe off previous versions of the drivers. If things are still not working after that, then you should consider your board is having no Bootloader. The best way to check that out is by pressing the reset button. If the LED by pin 13 is not blinking quickly every time you press it, then there is no Bootloader.


Like I said I have run all the basic diagnostics including that and also plugging in my own LED. which didn't work also.

Did you even download it and try?:X

Plugging in your own LED shouldn't be "basic diagnostics"... if you can't connect to it the LED won't do you any good:P

When you plug the board into the computer, does a Com port show up under Tools and Serial Port? If not, then it's probably what David suggested.. you just need to update your drivers.

If it does show up, and then you can't upload.. then make SURE you have the correct board selected. If you have the Duemilanove, it should reset automatically when you upload a sketch.. but something to try, push the upload button, hold down the reset button until the sketch compiles, then release.

But tell us what you have tried.. maybe some links.. explanations of why you think it's a bootloader problem?:)

Wait wait ...

when you say you are plugging your own LED .... you mean on pin 13?

If so ... if the on board LED is not blinking and your own LED is not blinking ... then you are in a situation where either the Bootloader is not there -as you mentioned- or there is no power on the board. This last extent you can check by looking if the power LED is on.

I assume you have already checked this. If you bought an original Arduino Duemilanove, then the bootloader should be there. And you should approach your distributor to reclaim a new board.

If you didn't buy an original board or if you made it yourself, then you are out in the wild. The next step is to burn the bootloader in your board. The way to do that is by using an ISP programmer like the one from Atmel or a USB-Tiny (the one manufactured by Ladyada).