help this dummy stop his arduino from restarting

OK guys first off i want to apologize for my ignorance here. I'm a Master Mechanic of 30 years with some engineering schooling 25 years ago but i am totally ignorant of what i am doing here and i need help. So basically i'm a dumb redneck and cannot understand whats going on.
I've searched the interweb for 4 days now trying to find a solution but what i read confuses me even more. It's like another language to me.

I have a Anycubic printer that runs the Mega 2560 board and the people at Anycubic are NO HELP at all!

The problem i have is that i can start a print and it works fine but at random times during the print it just stops and the whole thing resets itself.

Now i do have another problem with loading new firmware too. It says it uploads correctly but the parameters i change don't actually change.

I can live with that as eventually they do change it's just a pain in the Arse.

What i've tried is this.
I thought it was a power supply problem so i have tried 3 different power supply's. 2 new ones and the one that is on my Prusa printer.
So next i thought it might be a heat issue, so i lifted the unit off the table and placed a fan to circulate alot of air aound the board.
i thought maybe it was a gcode issue so i changed the parameters around (in simplify3d) to print slower and i tried faster.
Still nothing.

On a cold start the printer will print for about 20 minutes but after that it will only print about 3 to 5 minutes between each reset. Unless you let it sit overnight and then its the same thing all over again.

I'm lost guys and would really need some help. I only ask that you treat me like a dummy and walk me through it.

Thanks in advance for all the help.


The time correlation you've mentioned points very strongly to a thermal issue... somewhere.

Is anything getting hot? Check the regulator in particular, the SOT-223 part near the barrel jack. If you have a thermal IR camera, those can be useful for locating the hotspot - but most of us don't have one of those

How is power being supplied?

Can get a handheld "IR thermometer" at Home Depot for as little as $16, very handy tool.
We have a Ryobi brand unit, got it a couple of years ago for around $30, best they had in-store at the time.

For a little (okay, a lot) more, can get an IR add-on for your smart phone:

Browse the images, one of them is a list of compatible phones.
The reviews look ok too.

Yeah, Seek Thermal is the one I use - unfortunately I originally got it to be james bond, and got the longer range one, whereas it turns out that using it to look at overheating electronics (which wants the non-XR one) is much more useful in my life as not-james-bond. They're okay, but the XR one really doesn't work well for debugging electronics.

I have an IR thermometer for checking engines and i also have a SEEK thermal camera for the same reason. I'll check that tonight.
I did touch every single component (or at least i think i did) on the board, and nothing even felt warm.

As for power supplys, i've tried using the stock one that looks like a laptop cord. I've tried using the power supply that came with the heated bed kit i bought but have not installed yet and i've used the power supply off of my Prusa 3D printer that works well in that machine.

Thanks !

Another thing I'd try is hooking up the power rail (5v line of Arduino) to the oscilloscope (if you have one) and looking at whether it stays clean while the device is in operation.

I don't have that tool but i did put very nice accurate voltage meter and it never fluctuated during the time that it reset. It did fluctuate a little during startup but leveled out as the temps reached operating temp. I don't think 3 separate power units would have the same problem though

Well it looks like i was told incorrect info. Once again AnyCubic support sucks.

This is NOT a Arduino control board. its some knockoff called a TriGorrilla that they are using Arduino firmware on.

If you guys are still willing to help me i would appreciate it but if not i understand.

Again i know this is not an arduino product but i thought i'd share what i learned over the weekend.

No hot spots, no voltage problems. I tried raising it to 13 volts and dropping to 11, still no change.

So i tried printing again and got to watch a reset happen in front of me and it said no SD card right before it reset.

So i removed the card and printed from my laptop. it worked great until it had a very shaky section of the print on some infill.

So i wadded up 2 red rags and supported the circuit board and tried again. so last night i was able to get my first successful print.

to me that tells me i have a short in the board.

thanks for being so willing to help and i'm very sorry for not being knowledgeable enough to know that i didn't have the board i thought i did.

Y'all have great day.

TriGorilla board looks like nice hardware (just my first impression looking at the board) - and it uses a CP2102 serial adapter, instead of the mysteriously fragile 16u2's that the official megas have.

It sounds like your issue is a physical intermittent, if it's vibration sensitive. Could be a short (board vibrates, underside comes into contact with something metal, shorting the underside of the pins together) or a loose connection.