Help to configure Arduino Nano -> Xbee -> Android

Hi,

There are a number of threads regarding this topic, but I haven’t been able to troubleshoot my issue yet and haven’t seen much talk of using XBee-4 Nano. I am working on a Arduino/Android project where I need to have a remote XBee monitoring a button, once the button is pressed an notification is sent to my Android phone and I receive a message in the task bar saying the button was pressed.

I’ve been working on this for weeks… I’ve read many home automation book, walked through the XBee Lab manual, searched many forums, and installed the tools for Amarino. and the issue I’m having is not understanding how to get the XBee and Arduino to work enough to be discovered by . The Android portion I will be able to take care of.

The tools I have are

http://www.makershed.com/Xbee_Series_1_Starter_Kit_p/mkpx19.htm
(2) XBee 802.15.4 (Series 1) embedded-antenna modules.
(1) XBee USB Adapter for easy PC connection.
(1) XBee 5V/3.3V Adapter for microcontroller connection.

(2) XBee-4 Nano (shield for XBee and Arduino Nano)
(3) Arduino Nano
(1) Arduino Uno

X-CTU
Putty
Arduino IDE with Amarino
Android Phone

My ideal setup is connect configure XBee and Arduino Nano on the XBee-4 Nano shield to monitor a button, connect XBee/Arduino to Android phone, then on button press, phone receives a notification.

I am able to monitor the button and turn on LED on button press using the Adruino Nano. How do I sent this data from the Arduino to the XBee using XBee-4 Nano? Are the TX->RX and RX->TX already connected and the XBee will just broadcast the data, or do I need to manually set up jumpers to do this?

Next question is how do I discover the XBee module from my Android phone? I’ve watch numerous videos and I haven’t noticed anything I do not currently have, but probably missing something. I have successfully completed the Bluetooth chat project between my 2 XBee’s. I have installed the Amarino on my phone, but when I have the XBee hooked up to either of the adaptors or XBee-4 Nano, I am unable to discover the xbee. Why is this? Is there something with the baud rate or other setting I need to update to be able to do the discovery? Is the issue with the adaptor I am using? There is power to the XBee since I can light up an LED using D05 = 1 and ground.

If you can point me in the right direction on how to use the XBee-4 Nano and how to discover the XBee from an Android phone, it would be much appreciated.

Thanks

Hello there

I am in the same position as you are now. I am using the same xbee shield from Gravitech and I am having trouble establishing a connection with an UNO and a nano. Still no luck. I have searched allover the internet and posted a million threads but no one gets interested. I do not know if it helps but I dont think you need to manually connect the TX-RX pins to your board. Why am I saying this? When I am uploading my programs to my boards and the connection is on, the receiving LED on the xbee-4nano is blinking according to my TX led on the UNO xbee shield, meaning that those two are communicating. From my point of view, the problem may be in the nano side. I am getting the feeling that there must be a special configuration for this shield, or even some part o coding, for the nano to process the info received. I know it sounds stupid but honestly I have tried everything, even the simplest programs and nothing works.

I do not know if it helps to know that you are not alone in this, cause in terms of solutions I can give you nothing.

Please if you find something strange let me know.

Regards D

I don’t use garvitech shield but other, the problem is the same with arduino uno all is ok with"NANO every" doesn’t work. I don know why.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.