Help troubleshooting a board that won't show up in windows or linux.

Hello,

Very new to Arduino and I would appreciate your help.

I have an Arduino UNO R3 and yesterday I connected it to a Linux desktop (Ubuntu 18.04.3 LTS).
I installed the Arduino IDE and the board was seen and connected at port /dev/ttyACM0.
I had to run a chmod command against /dev/ttyACM0 and managed to upload the blink test from the basic examples.
I did nothing else except unplugging the board from my pc and storing it.

The next day I connected the board again (the green ON led is on, the amber led next to pin 13 is blinking and I see no other flashing led (nothing from the TX,RX for example).
From scetch, I checked tools Port and I see available /dev/ttyS0 and /dev/ttyS4. I do not see /dev/ttyACM0 in that menu.
I run the dmesg command and got lines back only for /dev/ttyS0 and /dev/ttyS4. Also, I run the ls /dev/tty* and didn’t see any records about ttyACM or ttyUSB.
I have tried connecting the board to different USB ports (usb3 and usb2) but no change.
I have also used a different, known to be good, USB cable from my printer. No change.

The sketch message when I try to upload:
An error occurred while uploading the sketch
avrdude: ser_open(): can't open device "/dev/ttyACM0": No such file or directory

I installed the latest version of Arduino IDE in windows10 laptop. I connected the same Arduino board but in the Windows version of Sketch the toopls->Ports is greyed out.
In the device manager, there isn’t a Ports(COM & LPT) section or Other Devices section.
When I installed the sketch software I did approve the installation of all drivers

The sketch message when I try to upload:
Board at null is not available

Can it be that the board just died from one day to the next?
Can you propose any extra troubleshooting?

Best Regards
Elias.

Make sure that the cable is fully inserted in both the Arduino and the PC. Not fully inserting might result in the power connections being ok but the data not being connected.

Hello and thanks for the response.

Sorry for not mentioning this at the initial post. With the two cables that I used, I made sure that the USB was all the way in. In the board and the PC.
It was something that was mentioned in some troubleshooting guides I found online. I checked again today and still the same behavior. The board light up but the Win10 or ubuntu machine doesn't see the Arduino.

Also from what I can see, there is no shorting on the board contacts.

Best Regards,
Elias.

Could you take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.

Posting tips.

  • Always list the version of the IDE you are using and the board version if applicable.
  • How to insert an image into your post. ( Thanks Robin2 )
  • Add your sketch where applicable but please use CODE TAGS ( </> )
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Guessing is not the best way to describe an issue. Actual facts are the most important.
  • Remember that the people trying to help cannot see your problem so give as much information as you can

I ordered a new board. I will see if this behaves differently.
If I report back I'll try following the forum guidelines.

Best regards,
Elias.