Help troubleshooting motor shield

Hello all,

A complete noob here, I've set up a wind simulator using monster Moto shield connected to nano, and two 2.7A fans

I acknowledge that I've done a poor soldering job, but it did work for a few days (fans worked fine spun up/down with signal from nano)
But all of a sudden it stopped working (fans no longer spins), and I'm having a hard time troubleshooting.

The shield itself seems to be receiving power, the power led is on, and I can see that it's getting 12v using multimeter
However both motor leds no longer lights up (as they previously were)

Looking at the motor output while idle it seems motor 1 is receiving 0.8v (800 Milliampere) while motor 2 is getting 50 Milliampere, not sure if this normal or indicative of a problem

Any advice on how to check/troubleshoot would be appreciated

Thanks

Product page at Sparkfun: https://www.sparkfun.com/products/retired/10182.

Can you show us a photo of the soldering ?
How strong is your 12V, how many amps can it supply ?
Which fans do you use ? Do they have a brand and a type ? Not every fan can deal with a PWM signal and some fans have a large startup current.

It is very hard to damage those driver chips. However, they can not deal with a reverse voltage. Perhaps something is not properly soldered and does no longer make contact.

Troubleshooting is done by cycling through all the options for each pin. Make it low and test it, make it high and test it, make it high impedance and test it, try the PWM.

Can you also tell what kind of soldering iron you use ?

Thanks for your reply, I really appreciate it
The PS is https://www.amazon.com/dp/B07K19MTKM?psc=1&ref=ppx_yo2_dt_b_product_details
it can handle 10A

The Fans are https://www.amazon.com/dp/B07FHM5DJZ?psc=1&ref=ppx_yo2_dt_b_product_details

The images are after I've already start to remove the soldering and disconnected one of the fans during my troubleshooting attempt

But it feels like I'm shooting in the dark without actually knowing what I'm doing, can you please elaborate on the process of troubleshooting, which pins do I need to touch with the multimeter what are the results I should expect? I assume not all pins are expected to have the same current?

Sorry for the stupid questions as I said I'm a complete noob

As for the soldering iron, I a cheap one that I got from one of those cheap electronic sites (I can't post more than two links so I can't give an exact link to the product) but it called DANIU-Professional-110V220V-60W

I've redone all of the soldering and now it works again.
Thanks again for the assistance

Very good :smiley:
The soldering did indeed need re-soldering.

Good:
afbeelding

Bad:
afbeelding

Worse:
afbeelding

The soldering iron is very cheap, but it should work. Give it a few minutes to get to the right temperature, but don't use a very high temperature.
You need better solder which is meant to solder electronics. This solder does not flow very well and there are brown splashes around the pins.