Help! Unable to upload codes!

Hello everyone, I'm new here and maybe the solution I've found had been posted earlier, but I couldn`t find it, so that's the story.

I was testing an serial programmer I've made for the 50$robot in the Arduino Uno cause I had problems programming it and didn´t kew if the programmer or the board were bad wired. I attached the programmer (the one I've done is based in this one http://www.societyofrobots.com/robotforum/index.php?topic=7626.0 to the ISP of the arduino and uploaded some .hex on it using ponyprog, clicking "ignore". Since the program was well uploaded and everything seemed to go right, I continued with the other board and left the Arduino for later.

Several days later I tried to upload some code on the Arduino uno using the USB inteface and the IDE and got the same error, the receiving led blinked three times but the sending one were always off. In somewhere between my confusion and my frustration I've recalled that I had programmed the board using the serial programmer and realized that probably it overwrote the bootloader. In this page http://arduino.cc/en/Hacking/Bootloader explains where to find the correct .hex for my board, in the \hardware\arduino\boards.txt, and uploaded it. That solved the problem. Seems that the big problem came cause ponyprog overwrites the entire flash, avrdude has an option to solve this, but I could't yet configure it to use the serial programmer I've made, but this is another story, and another hardware.

Hi All, just solve it by changing the port from COM3 to COM4 ....