Help with a 4-Relay Board

I have a Songle 4-relay board (like this one) that I'm trying to get up and running.

The IN1 pin on the module is connected to Pin 4 on my Arduino.
The VCC pin on the module is connected to the 5V power pin on my Arduino.
The GND pin on the module is connected to ground on my Ardunio.

I'm running this simple sketch that I hoped would open the relay for 3 seconds and then close the relay for 3 seconds.

int RelayControl1 = 4;    // Digital Arduino Pin used to control the motor
int RelayControl2 = 5;  
int RelayControl3 = 6;  
int RelayControl4 = 7;  
 
 
void setup()  
{   
  Serial.begin(9600);
  pinMode(RelayControl1, OUTPUT);
  pinMode(RelayControl2, OUTPUT);
  pinMode(RelayControl3, OUTPUT);
  pinMode(RelayControl4, OUTPUT);
}
 
 
void loop()  
{
  digitalWrite(RelayControl1,HIGH);  
  delay(3000);
  digitalWrite(RelayControl1,LOW); 
  delay(3000);
}

The led for IN1 on the relay module flashes on for 3 seconds and then off for three seconds.
The 5V rail on my breadboard (connected to relay module VCC) reads 5.00V when the IN1 LED is lit and drops to ~4.90V when IN1 LED is off (pulsing at the 3 second intervals expected from the sketch).

However, the relay doesn't seem to open. No audible click can be heard, and a continuity test across the normally open posts never beeps (the normally closed posts always have continuity).

Can anyone help me understand what steps I might be missing to get this relay to open/close?

Thanks so much!

The first thing to do is to replace that battery with a power supply capable of providing the required amount of current at a sufficient voltage for a reasonable time

Have you tried measuring the battery voltage when it is under load ?

Now powering the Arduino off of a 12V 40A (max) powersupply. I measure ~11.6V on the Arduino's VIN pin with the relay module hooked up and sketch running. Still no relay click or continuity between the normally open posts on relay 1 (I've tried the other relay's too with no success).

The VCC-JDVCC jack is still in on the relay module. Should I try disconnecting that and powering JDVCC with the 12V Arduino VIN line? I'm a bit out of my element with the hardware here. From other tutorials I've watched with similar boards it feels like the Arduino 5V line should be sufficient for the relay power, no?

Thanks again for the replies!

Check for power on that yellow jumper. That has to be 5V for the output side of the opto-isolators to drive the relay coils.

With the yellow jumper in place the voltage on VCC/JDVCC varries - ~3.8V when the opto-isolator is driven (red LED seen in the video is on), and 5.0V when it is off.

Gif of Voltage with Jumper

With the yellow jumper removed, I connected JDVCC to the Arduino's VIN and the voltage is a fairly steady 11.6V relative to Arduino's ground. However, the relay's still won't click open or show continuity between the normally open terminals :confused:

Gif of voltage with JDVCC connected to 12V VIN

Even on 12V? Maybe that opto-isolator is damaged. Have you tried the other relays? Have you tried 5V directly to the IN pin(s)?