Help with EAGLE

Hi everyone,

I recently downloaded EAGLE on the recommendation of forum member and made my first schematic (attached). Then when i try to make the board file, i notice some connections are missing. Also what should be my next step in finishing this board file (attached). I am looking to order top and bottom layer PCB with current < 1 Amps.

Thank you

Edit: The last picture is by using autoroute. I don’t know if it’s correct or how the board should look like.

what should be my next step in finishing this board

I am not familiar with Eagle, but it looks very much as though you do not have any PCB tracks defined

I only moved the components in the box and the last pic is by using auto route.

In the last image... there are traces (auto-route)

@OP

only you can know if its correct..

look at the schematic, and then go to the board file and follow the traces... does it connect with the correct part/end point?

Also.. you might want to do a GND pour.. using the poly tool (google it if need be)

Also looks as if some parts on the on the TOP and some o the bottom? (like your 4N35 parts?)

But again, only YOU know if thats how its supposed to be..

I would suggest following a tutorial first, it will explain many of the steps needed, such as;

https://learn.sparkfun.com/tutorials/using-eagle-schematic/all

https://learn.sparkfun.com/tutorials/using-eagle-board-layout

@xl97

I am trying to get the board made for the attached schematic.
The connections are not what they are supposed to be for most components.
I am providing GND from the Arduino and am looking to create a layer for components and other for traces.

1.) Do what @srnet suggests (they are good tutorials)

2.) If the schematic is correct… then the autorouting should connect ONLY the things that are connected in your schematic.

3.) The BRD file… is where YOU have placed things… and on what layer of the board (bottom or top)

Do you have the via layer turned on? Hard to see where the traces go… and where parts are placed…

“I am providing GND from the Arduino and am looking to create a layer for components and other for traces.”

This doesnt make sense to me???

If you make a GROUND POUR… then you dont need to make GND trace to all GND pins…etc…

“The connections are not what they are supposed to be for most components.”

Explain? Give an example of a part/trace that is NOT what your schematic shows?

Also… you should route this yourself, by hand. Autoroute is not great… but this is small component board… so should be fine… but in general I just route manually.

You might also want to look at https://www.instructables.com/id/Make-hobbyist-PCBs-with-professional-CAD-tools-by-/, which is specifically about modifying the autorouter design rules to make more "conservative" boards.