Help with Mega ADK

Hello,

I'm new to this forum, and in need of some guidance. I've used the UNO quite a bit, but i recently picked up a Mega ADK. I had managed to get the USB Host Shield Library working for the uno, but when i try with the ADK all i get is "OSC did not start." I've changed "avrpins.h" so that the Mega ADK is defined, but that didn't work. I've also tried downloading the USB Host Shield 2.0 Library, and changed the defining variable to a 1 in "settings.h", but that didn't work either. I've searched all over the internet and those are the only two solutions that i've found.

If anyone can help me, that would be awesome!

The Mega ADK has build in USB Host capabilities. Why do you need a shield, too?

Maybe i was a little vague there. I am trying to use the USB Host Shield library to access the usb host that is built into the board, but i keep getting the "OSC did not start" error.

After numerous failed attempts i decided to download the newest arduino 1.5.5 IDE, and that worked for me. Hopefully it works for anyone else having this problem.