help with the upload problem with Arduino Fio with FTDI cable


I am new to Arduino Fio.
After I hooked up a TTL-232R-3V3 FTDI cable to Fio, the red LED between Pin A7 and D13 on the Fio board slowly blinks. Is this correct?

The Ports in Device Manager only shows 'USB Serial Port (COM6)'. Is this correct?

I used Arduino 1.0. I verified the example "blink", it showed "Done compiling, Binary sketch size: 1050 bytes (of a 30720 byte maximum)". But when I tried uploading it, it showed "avrdude: stk500_getsync(): not in sync: resp=0x00". Could you let me know how to fix this problem?

By the way, when I connect the FTDI cable to the computer (win 7, 64bits OS), it didn't ask to install any drivers. I have also checked the settings of Board and Serial Port in the Tools menu, which are Fio and COM6. This seems to be correct.

I have also tried Arduino-0022, the results are
"avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51"

Thank you.