help with wifi-proto

hi i have a question about how connect this wi-fi (http://www.mikroe.com/downloads/get/1051/wifi_p_manual_v100.pdf) to an arduino one. Thank you :slight_smile:

i have a question about how connect this wi-fi...to an arduino one.

Are you going to ask it?

Yes i'm asking if anybody can explain me how connect this device to an arduino one. Sorry for my english, thank you

The module seems to use the same chip as the WiShield 2.0 from Asynclabs, so you probably can use their library (GitHub - asynclabs/WiShield: WiShield library for the Arduino development platform). Take a look at their wiki page about the shield to get an idea how to connect it: http://asynclabs.com/wiki/index.php?title=WiShield_2.0

Thank you !

Sorry but i'm new in that and i don't understand how to connect it. Somebody has more information?

GND to GND, Vcc probably to 3V3 (but this doesn't get clear from the "User Manual" sheet), MISO to pin 12, MOSI to pin 11, SCK to pin 13, INT to pin 2, CS to pin 10, RST to Reset, CE to GND. This is my best guess because your linked sheet does not include much information.

this days i have try that this works and i couldn't achieve. In this moment i'm connecting this ports:

CE -> GND
RST -> RESET
CS -> 10
INT -> 8
SCK -> 13
MOSI -> 11
MISO -> 10
BOTH VCC TO 3.3V
GND -> GND

And it doesn't work.
Anyone can help?

Thank you!

CS -> 10
MISO -> 10

This cannot work.

And you may destroy your module, I don't know if it's capable of receiving 5V on it's comm pins. You may have to install level converters.

INT -> 8

The default is pin 2, have you changed the library accordingly?

sorry, i mean MISO → 12. And yes, i changed the library.

I do the steps explain in this site: http://theiopage.blogspot.com.es/2011/10/connecting-mrf24wb0ma-to-arduino.html
And when i do the example that doesn’t work.

Thanks you!

And when i do the example that doesn't work.

You understand that this information is of almost no value to us. What doesn't work? What output do you get? What are you doing to get that output? Describe the network environment you're trying it. Post the code your trying with.

And yes, i changed the library.

Just to check: post the change you made.

in this web : http://theiopage.blogspot.com.es/2011/10/connecting-mrf24wb0ma-to-arduino.html

the example shows that when you open google xhrome and put the 192.168.1.2 in the navigator, arduino sens you a web. In my case this web doesn’t show.

the code is the next:

#ifdef USE_DIG8_INTR
// set digital pin 8 on Arduino
// as ZG interrupt pin
PCICR |= (1<<PCIE0);
PCMSK0 |= (1<<PCINT0);
#endif

#ifdef USE_DIG8_INTR
   // set digital pin 8 on Arduino
   // as ZG interrupt pin
   PCICR |= (1<<PCIE0);
   PCMSK0 |= (1<<PCINT0);
#endif

This is the relevant code but not the code that you should have changed. This is probably the reason it doesn’t work for you.

yes i have the same code and the connections that i said in the last post and it doesn't work :S.

EDIT: an image with hardware connections http://imageshack.us/f/855/20121113170322.jpg/.

Thank you

yes i have the same code and the connections that i said in the last post and it doesn't work :S.

If this is true, you haven't done the necessary change and it's obvious that it doesn't work.

You have to change in the file spi.h:

// Uncomment one line below to
// specify which Arduino pin
// to use as WiShield interrupt
#define USE_DIG0_INTR		// use digital pin 0
//#define USE_DIG8_INTR		// use digital pin 8

to

// Uncomment one line below to
// specify which Arduino pin
// to use as WiShield interrupt
//#define USE_DIG0_INTR		// use digital pin 0
#define USE_DIG8_INTR		// use digital pin 8

What kind of WiFi access point do you have? I made the experience that it doesn't work with every kind of access point, although with most APs I tested it worked (I have one type that doesn't work).

thank you pylon!

I've done the change but it still doesn't work. My access point is a linksys router wag325n.

Do you have the 802.11b activated on the router?

What authentication type do you have chosen on the router?

Post your sketch, so we can check the values. If possible also post the network values of your router or the network values you get on the notebook connected to that router.

finally i can get the response from the arduino. Thanks a lot!