Hi all, how come i cannot upgrade my arduino IDE on Mac to 1.0.3?

Hi all I installed IDE 0023 on my Mac, but when i tried to upgrade to 1.0, or 1.0.3, it not working at all. I mean when i double click on the app, nothing happened. Do anyone have any advice? thank you Yichen.Li